summaryrefslogtreecommitdiff
path: root/app-emacs/setup/setup-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-emacs/setup/setup-1.3.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-emacs/setup/setup-1.3.0.ebuild')
-rw-r--r--app-emacs/setup/setup-1.3.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/setup/setup-1.3.0.ebuild b/app-emacs/setup/setup-1.3.0.ebuild
new file mode 100644
index 000000000000..364818701e67
--- /dev/null
+++ b/app-emacs/setup/setup-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=26
+
+# The upstream does not create git tags for releases.
+MY_HASH=eece09d1151fd641f31d738b8c62742918993e95
+
+inherit elisp
+
+DESCRIPTION="Macro to simplify repetitive configuration patterns"
+HOMEPAGE="https://git.sr.ht/~pkal/setup"
+SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${MY_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_HASH}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}