summaryrefslogtreecommitdiff
path: root/app-emacs/rg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 15:07:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 15:07:39 +0000
commit52895d302231ef73b105756d2781b2262638d566 (patch)
tree7a2e0cf7cae8995cbbb6f9ae807d5c49b4f2b77c /app-emacs/rg
parent68f980204de6c2d69eed8748edc90282879326a6 (diff)
gentoo auto-resync : 02:02:2023 - 15:07:39
Diffstat (limited to 'app-emacs/rg')
-rw-r--r--app-emacs/rg/Manifest4
-rw-r--r--app-emacs/rg/files/50rg-gentoo.el2
-rw-r--r--app-emacs/rg/metadata.xml24
-rw-r--r--app-emacs/rg/rg-2.2.1.ebuild56
4 files changed, 86 insertions, 0 deletions
diff --git a/app-emacs/rg/Manifest b/app-emacs/rg/Manifest
new file mode 100644
index 000000000000..fe88638b47fb
--- /dev/null
+++ b/app-emacs/rg/Manifest
@@ -0,0 +1,4 @@
+AUX 50rg-gentoo.el 66 BLAKE2B 51ca91eda1462dcbcd9ae5bd917ab44b5e1259afd72bfb5cb8eb884dacca545677d00e0feac5e7d90f8b49c5f308afc354f5df08d2cca275e78e008fa15b94a7 SHA512 84a87f247455cfeadd80335fa686c1bfee28b3a006249fc5894880c2e2848bbe4795c71dd212bfc2aae5e599755ae335653e5a78457d1e04324b8b5ca82ed2b3
+DIST rg-2.2.1.tar.gz 202686 BLAKE2B 43abfdc5d631d5551272788dc31f8767f2b638604f180dfd0cb96df8d142f97ec644482da660c279f1877ab77477e5f25810de3850439d0210be1e4040c77a98 SHA512 eac9c21db6a13299e24f3e6166ff45f378f44454bc02ad8c04b42580d03c67eb28fbaee17feaa53096b7dced2e4e7dbf64a50608c61fe9188530fa0102a0f240
+EBUILD rg-2.2.1.ebuild 988 BLAKE2B 014d3b05938e9a85d8a24b3075c0ce0941811fdc66e14cd9c227b50dba49b05b38fef125829c7171a66e54d780e74a3e2821586645d289f32e86b14ccb55f2f2 SHA512 f8766cc1815e5c7ec3469ee99d7b19b7cea3183cf8e9389df07fe0309475ec56b89e6ce355392d99cf925d39df0ac6f8b7f89542c9b11bfcdfb1e4529b42a060
+MISC metadata.xml 1083 BLAKE2B aa777fe0b99335ca705401879d333e921bb480798c85a2213822461e4b60a5b8d660592d8dab7f1d81dff98dc2808aeff11992890842fc7657deee2516006288 SHA512 aca5ee92739a5e12ef60f539b74f2bb9449ec472d2ee2169528cb76cc716e0829427c9e3ddbb8ce7857266fc31a5143538a369afb59f5f00f26dd31e8af67d5c
diff --git a/app-emacs/rg/files/50rg-gentoo.el b/app-emacs/rg/files/50rg-gentoo.el
new file mode 100644
index 000000000000..df981fef423f
--- /dev/null
+++ b/app-emacs/rg/files/50rg-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "rg-autoloads" nil t)
diff --git a/app-emacs/rg/metadata.xml b/app-emacs/rg/metadata.xml
new file mode 100644
index 000000000000..f479f7c94178
--- /dev/null
+++ b/app-emacs/rg/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ A search package based on the ripgrep command line tool. It allows you to
+ interactively create searches, doing automatic searches based on the
+ editing context, refining and modifying search results and much more. It is
+ also highly configurable to be able to fit different users' needs. If you
+ are used to built-in Emacs rgrep command, transitioning to rg should be
+ simple. rg provides a lot of extra features but the basics are similar. The
+ big benefit of using ripgrep instead of grep as a backend is speed.
+ Especially when searching large source code repositories where ripgrep
+ really shines.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/dajva/rg.el/issues/</bugs-to>
+ <remote-id type="github">dajva/rg.el</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/rg/rg-2.2.1.ebuild b/app-emacs/rg/rg-2.2.1.ebuild
new file mode 100644
index 000000000000..f4b24b4f571d
--- /dev/null
+++ b/app-emacs/rg/rg-2.2.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs search tool based on ripgrep"
+HOMEPAGE="https://rgel.readthedocs.io/
+ https://github.com/dajva/rg.el/"
+SRC_URI="https://github.com/dajva/rg.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/rg.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ app-emacs/transient
+ app-emacs/wgrep
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ sys-apps/ripgrep
+"
+BDEPEND="
+ ${COMMON_DEPEND}
+ test? (
+ app-emacs/ert-runner
+ app-emacs/s
+ app-emacs/undercover
+ )
+"
+
+DOCS=( README.md )
+ELISP_REMOVE="test/rg.el-test.el test/rg-isearch.el-test.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}
+
+src_install() {
+ elisp_src_install
+ doinfo rgel.info
+}