summaryrefslogtreecommitdiff
path: root/app-emacs/psgml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/psgml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/psgml')
-rw-r--r--app-emacs/psgml/Manifest4
-rw-r--r--app-emacs/psgml/files/50psgml-gentoo.el6
-rw-r--r--app-emacs/psgml/metadata.xml12
-rw-r--r--app-emacs/psgml/psgml-1.4.0.ebuild33
4 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/psgml/Manifest b/app-emacs/psgml/Manifest
new file mode 100644
index 000000000000..44ac89587781
--- /dev/null
+++ b/app-emacs/psgml/Manifest
@@ -0,0 +1,4 @@
+AUX 50psgml-gentoo.el 295 BLAKE2B d2276bb66871f2dfeec692358fd49fa226c7141ff3b9e0020c05b7d873cf65fa1d4f117724ff3baf2ea3520bf85cdccd90129bf54da815bb44de19c279e0cddf SHA512 ecb9a8c544e0b5e287771d6538d36ab67076d0fc68b55bbc5428aa99b9c5f773f01499dad6f2d624d99648ddbb30518522da3f39d244fe30b4d884567114daa1
+DIST psgml-1.4.0.tar.gz 262246 BLAKE2B e888e7e13b39108efd19bbce41f3630015556ca9e5250665456866173302b5388add506694f28a6fa7e4e4572ce4596eec66762650f7203a14d84fcfbcd8ac7f SHA512 99bab6440a0f437009edff6371412c16f47d48c6b1eaa5b894523130e3a8d604ea79dc81f1895ceecd4283d0c7fd908d4e5bdeace63e54b9ac048a80fc0f6f44
+EBUILD psgml-1.4.0.ebuild 827 BLAKE2B e8425bab4b9f39686ba920f5c771a1a25565105cd1370ec6d7f2e5ea0587b5a3c0e3b614610d31e0bac5a82dae7b1142268fbfdb1fd0126d183358b5d02561ae SHA512 2e1778fa2efb8596b991314cfa0a3f43df0a9471aa3a4b44c8d8631d92479f3c14f3ab10b3dc911d27b46ee076c91c448e68ce621608b5c7463b3b7d664ef4a3
+MISC metadata.xml 355 BLAKE2B 8bf344b65a3b56830144a7413adbe5424f6cf1e043997982a961bd68c33538a6db10e42fb244150b7d77012ce3965cfbebe3b2dca3ccf39347c3391752cddc45 SHA512 8bffed60efe4fdef36e4abe3d9a7bce5617ce7da934a072cb52a26d8a935d0a78ddf8bc562033d59724bf0845f6ca60794ab54aa7ea76a755d4578d08f967ef4
diff --git a/app-emacs/psgml/files/50psgml-gentoo.el b/app-emacs/psgml/files/50psgml-gentoo.el
new file mode 100644
index 000000000000..e69efe77d8f0
--- /dev/null
+++ b/app-emacs/psgml/files/50psgml-gentoo.el
@@ -0,0 +1,6 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'sgml-mode "psgml" "Major mode to edit SGML files." t)
+(autoload 'xml-mode "psgml" "Major mode to edit XML files." t)
+(setq sgml-catalog-files '("CATALOG" "/etc/sgml/catalog"))
+(setq sgml-display-char-list-filename
+ "@SITEETC@/iso88591.map")
diff --git a/app-emacs/psgml/metadata.xml b/app-emacs/psgml/metadata.xml
new file mode 100644
index 000000000000..e3cf9243cef1
--- /dev/null
+++ b/app-emacs/psgml/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="sourceforge">psgml</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/psgml/psgml-1.4.0.ebuild b/app-emacs/psgml/psgml-1.4.0.ebuild
new file mode 100644
index 000000000000..4d38464f5803
--- /dev/null
+++ b/app-emacs/psgml/psgml-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="A GNU Emacs Major Mode for editing SGML and XML coded documents"
+HOMEPAGE="https://sourceforge.net/projects/psgml/
+ https://www.emacswiki.org/emacs/PsgmlMode"
+SRC_URI="http://www.fsavigny.de/gpled-software/${P}.tar.gz"
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="app-text/openjade"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ ${EMACS} ${EMACSFLAGS} --load psgml-maint.el -f psgml-compile-files || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ insinto "${SITEETC}/${PN}"
+ doins *.map
+ doinfo psgml.info psgml-api.info
+ dodoc ChangeLog INSTALL README.psgml psgml.ps
+}