summaryrefslogtreecommitdiff
path: root/app-emacs/planner/planner-3.42-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /app-emacs/planner/planner-3.42-r1.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'app-emacs/planner/planner-3.42-r1.ebuild')
-rw-r--r--app-emacs/planner/planner-3.42-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/planner/planner-3.42-r1.ebuild b/app-emacs/planner/planner-3.42-r1.ebuild
new file mode 100644
index 000000000000..5d5db2faa577
--- /dev/null
+++ b/app-emacs/planner/planner-3.42-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Maintain a local Wiki using Emacs-friendly markup"
+HOMEPAGE="https://www.emacswiki.org/emacs/PlannerMode"
+# taken from http://download.gna.org/planner-el/${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test"
+
+RDEPEND=">=app-emacs/muse-3.02.6a
+ app-emacs/bbdb
+ app-emacs/emacs-w3m"
+BDEPEND="${RDEPEND}
+ sys-apps/texinfo"
+PDEPEND="app-emacs/remember"
+
+SITEFILE="80${PN}-gentoo.el"
+ELISP_TEXINFO="planner-el.texi"
+DOCS="AUTHORS COMMENTARY ChangeLog* NEWS README"
+
+src_compile() {
+ default
+}