summaryrefslogtreecommitdiff
path: root/app-emacs/parseclj
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-12 15:25:12 +0000
commitdeac3ec728eccad6c6929b2699ced3580deeadcd (patch)
tree1b2bd95136e398dcc801453323b2dad3ce3d3949 /app-emacs/parseclj
parent09d1923fc1fee6007fbd5692399ffa7fbff7e410 (diff)
gentoo auto-resync : 12:12:2022 - 15:25:12
Diffstat (limited to 'app-emacs/parseclj')
-rw-r--r--app-emacs/parseclj/Manifest4
-rw-r--r--app-emacs/parseclj/files/50parseclj-gentoo.el1
-rw-r--r--app-emacs/parseclj/metadata.xml18
-rw-r--r--app-emacs/parseclj/parseclj-1.1.0.ebuild28
4 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/parseclj/Manifest b/app-emacs/parseclj/Manifest
new file mode 100644
index 000000000000..bc361e86b52b
--- /dev/null
+++ b/app-emacs/parseclj/Manifest
@@ -0,0 +1,4 @@
+AUX 50parseclj-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST parseclj-1.1.0.tar.gz 37228 BLAKE2B d0e74eeb3a1ea9cec7445f3e2627d8d6287ff476fdff4a1dd9b3f58100621a02fc0f0369b96bd92fa8f43485d8c45ffa0a7d41681dfe71020157ca467325e2b9 SHA512 ef8da1f65d4f873c81a785aae495128dc551b73cc89cda7c8b37ce8be15b7473c6cbcd886d5ea285ae414a05a02109b60a8cd933720f1a4b6a1e63e07ec33cf8
+EBUILD parseclj-1.1.0.ebuild 617 BLAKE2B 55c2293dc12e5627da0047415655310f50bf2f581d72f6c450df27ffb41ce0622f3de90fb68b5721fd6bff2f54e049037b6355242918bca275e8867f8734b97f SHA512 0616f78c68e3383cf350b014bd4d594cedca3fa24a373483f5e8a0a3ded9ca33fd15a49cb14a67a97cdff7d619d6c87cd2d94a272a552274a67b310f83b7d6dd
+MISC metadata.xml 659 BLAKE2B 0228d25161ab040e3d14af307f53239c39da58b5980d1a5bbe4628df1d9559e027a91ed345c696dbc910f75249dabe57a1f518ed74c06d48058a670b0249a35c SHA512 fde89c6cf6f7b41304a1824ec54cfd3293bc197cb7321b89ad9f8009b26f2376f6f62d920fc43d9e0b81851387c38d58e0cef86f3c39984572f642607f5f876e
diff --git a/app-emacs/parseclj/files/50parseclj-gentoo.el b/app-emacs/parseclj/files/50parseclj-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/parseclj/files/50parseclj-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/parseclj/metadata.xml b/app-emacs/parseclj/metadata.xml
new file mode 100644
index 000000000000..c7ad27b76ae9
--- /dev/null
+++ b/app-emacs/parseclj/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ parseclj is an Emacs Lisp library for parsing Clojure code and EDN data. It
+ supports several input and output formats, all powered by the same
+ shift-reduce parser function.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/clojure-emacs/parseclj/issues/</bugs-to>
+ <remote-id type="github">clojure-emacs/parseclj</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/parseclj/parseclj-1.1.0.ebuild b/app-emacs/parseclj/parseclj-1.1.0.ebuild
new file mode 100644
index 000000000000..0adbdc6b45d8
--- /dev/null
+++ b/app-emacs/parseclj/parseclj-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Clojure Parser for Emacs Lisp"
+HOMEPAGE="https://github.com/clojure-emacs/parseclj/"
+SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/ert-runner )"
+
+DOCS=( CHANGELOG.md DESIGN.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ert-runner -L . -L test --reporter ert+duration --script test || die
+}