summaryrefslogtreecommitdiff
path: root/app-emacs/paredit/paredit-25.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 19:15:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 19:15:12 +0000
commitb3e456d42287ef73c7ff48148d18a9ea8fb8debf (patch)
tree1c9ad46437b76c8af060cd54ff3ceb0f8678b6ce /app-emacs/paredit/paredit-25.ebuild
parent7de40ae3e1ba40671bc9aac9ebbf3f42952a036b (diff)
gentoo auto-resync : 26:11:2022 - 19:15:12
Diffstat (limited to 'app-emacs/paredit/paredit-25.ebuild')
-rw-r--r--app-emacs/paredit/paredit-25.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-emacs/paredit/paredit-25.ebuild b/app-emacs/paredit/paredit-25.ebuild
new file mode 100644
index 000000000000..8510221c5950
--- /dev/null
+++ b/app-emacs/paredit/paredit-25.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minor mode for performing structured editing of S-expressions"
+HOMEPAGE="https://paredit.org https://www.emacswiki.org/emacs/ParEdit"
+SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( ${PN}.html )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -l ${PN}.el -l test.el || die 'tests failed'
+}