summaryrefslogtreecommitdiff
path: root/app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild')
-rw-r--r--app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild b/app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild
new file mode 100644
index 000000000000..639661441bd5
--- /dev/null
+++ b/app-emacs/nxml-svg-schemas/nxml-svg-schemas-1.1.20081123.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with SVG 1.1 schemas"
+HOMEPAGE="http://www.w3.org/TR/SVG11/"
+# original SRC_URI is http://www.w3.org/Graphics/SVG/1.1/rng/rng.zip
+# but since it's unversioned, I versioned it and got it locally.
+SRC_URI="http://www.flameeyes.eu/gentoo-distfiles/w3c-svg-rng-${PV}.zip"
+
+LICENSE="HPND"
+# In a future we might have 1.2 schemas too, but for now we can only
+# install this one anyway because the schemas.xml syntax is not
+# sophisticated enough.
+SLOT="1.1"
+KEYWORDS="amd64 ~x86"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+DEPEND="app-text/trang"
+RDEPEND=""
+
+S="${WORKDIR}"
+SITEFILE="60${PN}-gentoo.el"
+
+src_prepare() {
+ # we don't need the doctype for our work
+ sed -i -e '/DOCTYPE grammar/d' *.rng || die "sed failed"
+}
+
+src_compile() {
+ emake -f "${FILESDIR}/Makefile-trang"
+}
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins "${FILESDIR}/schemas.xml" *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}