summaryrefslogtreecommitdiff
path: root/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-02 10:16:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-02 10:16:02 +0100
commit02fbebe9426ee05ab39e9b5a56e3529e64160ef6 (patch)
tree4c2a5db6966711f46fbc73aece931b17625e27b7 /app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.7.0.ebuild
parentb052fbf151106a4f47cac7fdf0ffff983decb773 (diff)
gentoo auto-resync : 02:09:2022 - 10:16:01
Diffstat (limited to 'app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.7.0.ebuild')
-rw-r--r--app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.7.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.7.0.ebuild b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.7.0.ebuild
new file mode 100644
index 000000000000..1c0188f9655a
--- /dev/null
+++ b/app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-8.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+inherit elisp
+
+MY_P="libvirt-${PV}"
+DESCRIPTION="Extension for nxml-mode with libvirt schemas"
+HOMEPAGE="https://www.libvirt.org/"
+SRC_URI="https://libvirt.org/sources/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P%-rc*}/src/conf/schemas"
+
+# This is the license of the package, but the schema files are
+# provided without license, maybe it's bad.
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Yes this requires Java, but I'd rather not repackage this, if you
+# know something better in C, I'll be glad to use that.
+BDEPEND="app-text/trang"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() {
+ emake -f "${FILESDIR}"/Makefile-trang
+}
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins "${FILESDIR}"/schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}