summaryrefslogtreecommitdiff
path: root/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
commita87296ad796f00f3bba27339f6efe11b9a384e23 (patch)
tree1a47aa193935e1eb80c6ce1c7ececdcf9d44dfb3 /app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild
parent724cccb689f2076a398ede6845749926c86ea647 (diff)
gentoo auto-resync : 27:02:2023 - 22:02:09
Diffstat (limited to 'app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild')
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild
new file mode 100644
index 000000000000..94311b25501f
--- /dev/null
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="https://gitweb.gentoo.org/proj/nxml-gentoo-schemas.git/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}