summaryrefslogtreecommitdiff
path: root/app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 05:05:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 05:05:05 +0100
commit836586553c510ee2dd91e2ecd7676fe432c1f1a4 (patch)
tree38ac002e272f81097f4d65e1e8c94625d291f358 /app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild
parent89553b6b47f66268074b385593005eacd7b65ccf (diff)
gentoo auto-resync : 18:09:2023 - 05:05:05
Diffstat (limited to 'app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild')
-rw-r--r--app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild b/app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild
new file mode 100644
index 000000000000..eb4ac623a02f
--- /dev/null
+++ b/app-emacs/mmm-mode/mmm-mode-0.5.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Enables the user to edit different parts of a file in different major modes"
+HOMEPAGE="http://mmm-mode.sourceforge.net/
+ https://github.com/dgutov/mmm-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dgutov/${PN}.git"
+else
+ SRC_URI="https://github.com/dgutov/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS=( AUTHORS FAQ NEWS README README.Mason TODO )
+ELISP_TEXINFO="mmm.texi"
+SITEFILE="50${PN}-gentoo.el"