summaryrefslogtreecommitdiff
path: root/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild')
-rw-r--r--app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild b/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
new file mode 100644
index 000000000000..33487fa8e1bb
--- /dev/null
+++ b/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Major modes for MATLAB .m and .tlc files"
+HOMEPAGE="http://matlab-emacs.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+S="${WORKDIR}/matlab-emacs-src"
+SITEFILE="50${PN}-gentoo-3.3.6.el"
+DOCS="README.org INSTALL ChangeLog*"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file matlab-load.el
+}