summaryrefslogtreecommitdiff
path: root/app-emacs/mastodon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 06:02:21 +0100
commit32c16465e56b0122cf6e5a4625e9c7b56b107b07 (patch)
tree600c43152c825fda5f210dd7cb52b357eb6f2602 /app-emacs/mastodon
parent607c0755d4f6476e326fb33795df7216a7bcff18 (diff)
gentoo auto-resync : 08:10:2023 - 06:02:21
Diffstat (limited to 'app-emacs/mastodon')
-rw-r--r--app-emacs/mastodon/Manifest4
-rw-r--r--app-emacs/mastodon/mastodon-1.0.6.ebuild28
-rw-r--r--app-emacs/mastodon/metadata.xml1
3 files changed, 32 insertions, 1 deletions
diff --git a/app-emacs/mastodon/Manifest b/app-emacs/mastodon/Manifest
index 0ceea3ad92e5..f922ee944393 100644
--- a/app-emacs/mastodon/Manifest
+++ b/app-emacs/mastodon/Manifest
@@ -1,4 +1,6 @@
AUX 50mastodon-gentoo.el 137 BLAKE2B 1a4d306658bc54fa3b69a6b250a9fc48d8013e79261afad49b71e01fa0096c6f81187eeb4a308d19888045be948c8cf3d726e9ee9865120cb803be2f35969892 SHA512 52bffd9a794108da342152e435aba1fb551e5f058e1ff02d0a094b221a6b1359e39d0bf629472d5e42fff43244303d78cc4bfd7052f5760b512a61d18300074b
DIST mastodon-1.0.0.tar.gz 91448 BLAKE2B 093599c4e80113fcb91e0419f3fd050dc793965ce5b69ac94aaabefa5c51cf1b02bb9d8b9bb60a6b5cab377780958b30254f0d91c0f3f8309c1b04342415b17d SHA512 206b180e1cbb345ef35182f753e05b57d5ef1649c68aa3a8ff8eee3c4e3157a22457398a04219f4fd052e8af9d94f6978a6c95c399e284eb27449cd9a4c53e8c
+DIST mastodon-1.0.6.tar.gz 151149 BLAKE2B a8ee84902acb1b84e80d4273a978e6e6d636a13ab64fdb896d3c3fa8894e2f80a8b164de9e45b1e6ef022c898a8297d5b37b6975f44ccfa3135b254d7a366410 SHA512 0225461d234a12cd17ecfdd208a5854d16b1d466362f6953e1e0defb5f1f59c09c1fbd0b94061d3103d1728c0b16ed3666a993e6d99b2057fc28715b4b56806e
EBUILD mastodon-1.0.0.ebuild 549 BLAKE2B b7e318d8ccea77824e4d3aa516e9220c5ef8212607947a2de03277a9f46e8341512f846fe205d781635fca6ed68f8a418ee07fce060dd40766ef7f273436b468 SHA512 e52bfde37268c66d66efd6c1078159daf77b7d124661e4c93bfaae51cc89cace746b3de30d2fc2935223d551156a26bf5b19274618504051848bc2e49eb2012a
-MISC metadata.xml 448 BLAKE2B 6e886586bfa014f72cc40c103bb3901223a6050e10995929b3f709e275e360c750a5cc6940611575d822b160b37c4d4873ac3b191c3a2ad766c34b6c4b1db265 SHA512 86340bfaa0851d176025f23869cc4b29f0883ed4a1bbd4b615fd9af998aa2e36e5cd887538c88810ed4148628340025c7078a9114d10441f425cbd7ba53c64c3
+EBUILD mastodon-1.0.6.ebuild 599 BLAKE2B 223b27a85960ee3c0edd4463117ddcfd863a798db59dd6551fc1208628006f557642d2a22281bd5c32da5a966c5cabb499f38e7db0465bb1d8efdc5b8a2aaf7f SHA512 4d0bdb4f1cc48eec9a3d6bd75b5a090b93c36fc6bb02ed218a19caa60048966aabf19923c3fe94e18ea62edde51fcdc8f72fbd6ad902deae02c27076f2516aff
+MISC metadata.xml 512 BLAKE2B d8a604d5c6c58e2851d87c5602398d8bbc654a537febc54faad53815db5f527e507e1d45d75b0326db05dd747e315003b82e220fd494ad89c85ff7e951dbc563 SHA512 12b0ab3aeee03e66c3eac83b7ce581eee6110bc469681f7b0979c45110d651c19c5362d780886d95e2eaffdaba3fca44a00991e99f155312ba51cd4726ac4464
diff --git a/app-emacs/mastodon/mastodon-1.0.6.ebuild b/app-emacs/mastodon/mastodon-1.0.6.ebuild
new file mode 100644
index 000000000000..007a6a1b40d9
--- /dev/null
+++ b/app-emacs/mastodon/mastodon-1.0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs client for Mastodon, federated microblogging social network"
+HOMEPAGE="https://codeberg.org/martianh/mastodon.el/"
+SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.el/lisp"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/persist
+ app-emacs/request
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( ../README.org )
+ELISP_TEXINFO="../${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/mastodon/metadata.xml b/app-emacs/mastodon/metadata.xml
index ca48e9f3432a..2e247f944b94 100644
--- a/app-emacs/mastodon/metadata.xml
+++ b/app-emacs/mastodon/metadata.xml
@@ -9,5 +9,6 @@
<upstream>
<changelog>https://codeberg.org/martianh/mastodon.el/releases/</changelog>
<bugs-to>https://codeberg.org/martianh/mastodon.el/issues/</bugs-to>
+ <remote-id type="codeberg">martianh/mastodon.el</remote-id>
</upstream>
</pkgmetadata>