summaryrefslogtreecommitdiff
path: root/app-emacs/magit/magit-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-28 21:15:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-28 21:15:34 +0100
commit14bda3c9c57c13e8a59303f400678313fd770bdd (patch)
tree1d76323e4e249e0515128cd6ca42e167a9575294 /app-emacs/magit/magit-9999.ebuild
parente5346f2f512bd7faf413f3de3ef7fbcfbcd974b3 (diff)
gentoo auto-resync : 28:05:2023 - 21:15:34
Diffstat (limited to 'app-emacs/magit/magit-9999.ebuild')
-rw-r--r--app-emacs/magit/magit-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/magit/magit-9999.ebuild b/app-emacs/magit/magit-9999.ebuild
new file mode 100644
index 000000000000..031034b86493
--- /dev/null
+++ b/app-emacs/magit/magit-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/magit.git"
+else
+ SRC_URI="https://github.com/magit/magit/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${S}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../README.md ../docs/AUTHORS.md ../docs/RelNotes )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.3.6
+ >=app-emacs/with-editor-3.0.5
+ app-emacs/libegit2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.0.0
+"
+
+src_prepare() {
+ default
+
+ echo "(setq magit-version \"${PV}\")" > magit-version.el || die
+}