summaryrefslogtreecommitdiff
path: root/app-emacs/lookup/lookup-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/lookup/lookup-1.4.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/lookup/lookup-1.4.1.ebuild')
-rw-r--r--app-emacs/lookup/lookup-1.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/lookup/lookup-1.4.1.ebuild b/app-emacs/lookup/lookup-1.4.1.ebuild
new file mode 100644
index 000000000000..77d227163e10
--- /dev/null
+++ b/app-emacs/lookup/lookup-1.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="An interface to search CD-ROM books and network dictionaries"
+HOMEPAGE="http://openlab.jp/edict/lookup/"
+SRC_URI="http://openlab.jp/edict/lookup/dist/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+ELISP_PATCHES="${P}-garbage-char.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+}
+
+src_compile() {
+ # parallel make fails with Emacs deadlock
+ emake -j1
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS ChangeLog NEWS README
+}