summaryrefslogtreecommitdiff
path: root/app-emacs/lice-el
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 22:34:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 22:34:14 +0100
commit3a77d78ca92715b58ddac074baa5b25c4baf9a9b (patch)
tree6dc147c4f02d9c37807f61c29d1fad916f967a94 /app-emacs/lice-el
parent785047acce64d1217286105397cc6fe433c34cb3 (diff)
gentoo auto-resync : 09:09:2023 - 22:34:14
Diffstat (limited to 'app-emacs/lice-el')
-rw-r--r--app-emacs/lice-el/Manifest5
-rw-r--r--app-emacs/lice-el/files/50lice-el-gentoo.el3
-rw-r--r--app-emacs/lice-el/files/lice-el-0.3-siteetc.patch12
-rw-r--r--app-emacs/lice-el/lice-el-0.3.ebuild39
-rw-r--r--app-emacs/lice-el/metadata.xml13
5 files changed, 72 insertions, 0 deletions
diff --git a/app-emacs/lice-el/Manifest b/app-emacs/lice-el/Manifest
new file mode 100644
index 000000000000..a3c27a06e2ec
--- /dev/null
+++ b/app-emacs/lice-el/Manifest
@@ -0,0 +1,5 @@
+AUX 50lice-el-gentoo.el 96 BLAKE2B 85aafe59deed0b7fde44bc4cdd10a9a3b17fd64a35d42a9618f4e6c350543e0fd09e520eace4a822c341a11fc47155aba56491417a7e8f456d58391d6034279a SHA512 94a21da466422c4f57cf35b9bff680e822f46f258ad92e1856b4d5a7873454abbeefbce92c12018c235efa3e5c696d1b3df641e18567db221bec43c036d0a7bd
+AUX lice-el-0.3-siteetc.patch 379 BLAKE2B 0056e31198185c57c1c95a34ba408795e9f009384e1b973f6334bc4decd6030c41e3a42aa71230a411c6fba0ef834d915c391bb095e888cb465a5e75ec848bc9 SHA512 ab59b71df477ef83e3c6824ed8522c9724dfe7997b5a4c3a8c7a3ed90c2c03ecb8b56241da38dd824a4a3ca4f6f6fe72da702c19d48c3de0750a2df94d8573c3
+DIST lice-el-0.3.tar.gz 18587 BLAKE2B 5bf04f3aab3a1cc6f2729978f6d4b95af9fece7df0d44ae49e61a98277552b26ab2fca567faf8daa6e38eb44d7b446b60c4b02cf178ef6d9f8b5e744c783ecd8 SHA512 a00b68b1c54848588c432f5120f8b45edf3ef9933fc8d2e38d798222adf1fbc34dc7fe34216b12c8b42815dcb68865dafb75efbd07ec7a69f23c235c8648d634
+EBUILD lice-el-0.3.ebuild 762 BLAKE2B 811694949fdd8a86f22c96099195fc1263a81da0af3c7266d09a0348d55858a0f13fe9bf536084b5dd74327662b9fea60af6521dbb8915af2442134994b12f64 SHA512 edc3086b87d7a280044620774349084b9dff71d966507496fd9950c29d11b484b9b47d8ce3547d4da3fb39b49d77ccbd253cd5164133288923d72513367164e9
+MISC metadata.xml 423 BLAKE2B e38ff90d3ab113cfc7fcc8f162e8fd2cda0dbe462b213eecccc19899c1ebb02ff5d3191fe7a36163ad7a46cb479c9c890ed219e7d8ec750b0c2a9a345a884d05 SHA512 13d93998ea35f389f3a708eebcb01652e989fd77a6928546f6750b7ad1d99acb2ec1772e454c90c31a4b599c7d929b2f1c72b1e40c71a2eb0916a581f731917b
diff --git a/app-emacs/lice-el/files/50lice-el-gentoo.el b/app-emacs/lice-el/files/50lice-el-gentoo.el
new file mode 100644
index 000000000000..c249663fc2fa
--- /dev/null
+++ b/app-emacs/lice-el/files/50lice-el-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'lice "lice"
+ "Insert license and headers." t)
diff --git a/app-emacs/lice-el/files/lice-el-0.3-siteetc.patch b/app-emacs/lice-el/files/lice-el-0.3-siteetc.patch
new file mode 100644
index 000000000000..264bb1828100
--- /dev/null
+++ b/app-emacs/lice-el/files/lice-el-0.3-siteetc.patch
@@ -0,0 +1,12 @@
+--- a/lice.el
++++ b/lice.el
+@@ -57,8 +57,7 @@
+
+ (defconst lice:system-template-directory
+ (expand-file-name "template"
+- (or (and load-file-name (file-name-directory load-file-name))
+- default-directory)))
++ "@SITEETC@"))
+
+ (defvar lice:custom-template-directory
+ (expand-file-name "lice" user-emacs-directory))
diff --git a/app-emacs/lice-el/lice-el-0.3.ebuild b/app-emacs/lice-el/lice-el-0.3.ebuild
new file mode 100644
index 000000000000..6cbd1e127c7f
--- /dev/null
+++ b/app-emacs/lice-el/lice-el-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="License and header template for GNU Emacs"
+HOMEPAGE="https://github.com/buzztaiki/lice-el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/buzztaiki/${PN}.git"
+else
+ SRC_URI="https://github.com/buzztaiki/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-0.3-siteetc.patch" )
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ sed -i "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" lice.el || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r template
+}
diff --git a/app-emacs/lice-el/metadata.xml b/app-emacs/lice-el/metadata.xml
new file mode 100644
index 000000000000..049a47d44e2d
--- /dev/null
+++ b/app-emacs/lice-el/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/buzztaiki/lice-el/issues/</bugs-to>
+ <remote-id type="github">buzztaiki/lice-el</remote-id>
+ </upstream>
+</pkgmetadata>