summaryrefslogtreecommitdiff
path: root/app-emacs/js2-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 04:25:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 04:25:47 +0100
commitf5d9305cc82b2e211fdaba92618c07829ffb2c48 (patch)
tree430648fb68a5308f8831702d5a970e476ca4e91c /app-emacs/js2-mode
parent0234994edb2122d4508c5a07122e774bcab9195b (diff)
gentoo auto-resync : 06:09:2022 - 04:25:47
Diffstat (limited to 'app-emacs/js2-mode')
-rw-r--r--app-emacs/js2-mode/Manifest4
-rw-r--r--app-emacs/js2-mode/files/50js2-mode-gentoo.el12
-rw-r--r--app-emacs/js2-mode/js2-mode-20220710.ebuild23
-rw-r--r--app-emacs/js2-mode/metadata.xml27
4 files changed, 66 insertions, 0 deletions
diff --git a/app-emacs/js2-mode/Manifest b/app-emacs/js2-mode/Manifest
new file mode 100644
index 000000000000..dd95ce004ba0
--- /dev/null
+++ b/app-emacs/js2-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50js2-mode-gentoo.el 587 BLAKE2B ad7f81b78d3b190c56980d3c57a937f6a9088d7af70363e8648c7e53c3f84c9cc4a2fc5a939970fd3f84a678a32f05d8a46889d0f3582bfc32c0753e913260bb SHA512 2c32fd76a21edbc2be01fafa1c77e4374eac03f0d7813faf41738ba3adaafb0953778db5c0382a4ee62312120c50853fb2ea3f56302269279e33e9d8a98361ed
+DIST js2-mode-20220710.tar.gz 166051 BLAKE2B f23f122f9002a38d1d6221f2f0f85efd9a9be92f7c5a242da3b3706abb9ec93e27e2f277e4cb1b7cd3ed616974add9f5ffd1abcf1ced6c7131d91b66320bd0e7 SHA512 7a30903114f81fe66bc76eecb01f8d96737f4be84c652f1083054ffdcda299d84c7d7fea387c87f719e2dc372459fcc180dde0513ed3006b8f12557e24002727
+EBUILD js2-mode-20220710.ebuild 462 BLAKE2B eb8c82ed92aefd0a224d49293ca5ba2bbf077fbcbb62d9df549e14da455adfe962e681f391c8f1251beb553f1adbeddf4094dd3d67107463c724b2f8e98f9029 SHA512 292dace7df6718161b2796e63322e78b76e0b4ae5bd0bee2f20dcc07449d2f2256a825c157c9f2e7924301fad2c9c18ca2911ac777adedd37f699f13cca6b862
+MISC metadata.xml 1312 BLAKE2B 5307407d05ae0605644c4464af5ad60d2a2e6d329bf6887fcac942e165b941fa38c506047e92f34cd49852f0726f0e4c083f18975ea72afef7e186869ad22d42 SHA512 0100481ef0e97b6de436d65f9574b66d234475ca73e4b7f35a0a0b1e790683fd22528bb5f3e0596396aa7b9431a6b37776a98d2530072697988a1553a4478c91
diff --git a/app-emacs/js2-mode/files/50js2-mode-gentoo.el b/app-emacs/js2-mode/files/50js2-mode-gentoo.el
new file mode 100644
index 000000000000..12daf0e43291
--- /dev/null
+++ b/app-emacs/js2-mode/files/50js2-mode-gentoo.el
@@ -0,0 +1,12 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'js2-imenu-extras-setup "js2-imenu-extras")
+(autoload 'js2-imenu-extras-mode "js2-imenu-extras"
+ "Toggle Imenu support for frameworks and structural patterns." t)
+(autoload 'js2-highlight-unused-variables-mode "js2-mode"
+ "Toggle highlight of unused variables." t)
+(autoload 'js2-minor-mode "js2-mode"
+ "Minor mode for running js2 as a background linter." t)
+(autoload 'js2-mode "js2-mode"
+ "Major mode for editing JavaScript code." t)
+(autoload 'js2-jsx-mode "js2-mode"
+ "Major mode for editing JSX code in Emacs 26 and earlier." t)
diff --git a/app-emacs/js2-mode/js2-mode-20220710.ebuild b/app-emacs/js2-mode/js2-mode-20220710.ebuild
new file mode 100644
index 000000000000..1d502b22e198
--- /dev/null
+++ b/app-emacs/js2-mode/js2-mode-20220710.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.1
+
+inherit elisp
+
+DESCRIPTION="Improved JavaScript editing mode for GNU Emacs"
+HOMEPAGE="https://github.com/mooz/js2-mode/"
+SRC_URI="https://github.com/mooz/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( NEWS.md README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test
+}
diff --git a/app-emacs/js2-mode/metadata.xml b/app-emacs/js2-mode/metadata.xml
new file mode 100644
index 000000000000..2983ab1f4170
--- /dev/null
+++ b/app-emacs/js2-mode/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This JavaScript editing mode supports: 1. strict recognition of the
+ Ecma-262 language standard 2. support for most Rhino and SpiderMonkey
+ extensions from 1.5 and up 3. parsing support for ECMAScript for XML (E4X,
+ ECMA-357) 4. accurate syntax highlighting using a recursive-descent parser
+ 5. on-the-fly reporting of syntax errors and strict-mode warnings 6.
+ undeclared-variable warnings using a configurable externs framework 7.
+ "bouncing" line indentation to choose among alternate indentation points 8.
+ smart line-wrapping within comments and strings 9. code folding: 9.1. show
+ some or all function bodies as {...} 9.2. show some or all block comments
+ as /*...*/ 12. context-sensitive menu bar and popup menus 13. code browsing
+ using the `imenu' package 14. many customization options
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/mooz/js2-mode/issues/</bugs-to>
+ <remote-id type="github">mooz/js2-mode</remote-id>
+ </upstream>
+</pkgmetadata>