summaryrefslogtreecommitdiff
path: root/app-emacs/helm/helm-3.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-13 18:49:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-13 18:49:18 +0000
commitf8d671851faf1ca201cec0490ead4642c8987bae (patch)
treeb8fa88a5eb1312b7f587c4670cf04cb4003e7714 /app-emacs/helm/helm-3.9.0.ebuild
parent7c1ac01728d0156998ee45be74f80b378d96c31d (diff)
gentoo auto-resync : 13:11:2022 - 18:49:18
Diffstat (limited to 'app-emacs/helm/helm-3.9.0.ebuild')
-rw-r--r--app-emacs/helm/helm-3.9.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/helm/helm-3.9.0.ebuild b/app-emacs/helm/helm-3.9.0.ebuild
new file mode 100644
index 000000000000..59c678741fd3
--- /dev/null
+++ b/app-emacs/helm/helm-3.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.8.8-no-autoload-check.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}