summaryrefslogtreecommitdiff
path: root/app-emacs/helm/helm-3.8.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-emacs/helm/helm-3.8.6.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-emacs/helm/helm-3.8.6.ebuild')
-rw-r--r--app-emacs/helm/helm-3.8.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/helm/helm-3.8.6.ebuild b/app-emacs/helm/helm-3.8.6.ebuild
new file mode 100644
index 000000000000..68aff2bea3b6
--- /dev/null
+++ b/app-emacs/helm/helm-3.8.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+PATCHES="${FILESDIR}/${PN}-3.8.0-no-autoload-check.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ dobin emacs-helm.sh
+}