summaryrefslogtreecommitdiff
path: root/app-emacs/helm/helm-3.8.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /app-emacs/helm/helm-3.8.5.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'app-emacs/helm/helm-3.8.5.ebuild')
-rw-r--r--app-emacs/helm/helm-3.8.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/helm/helm-3.8.5.ebuild b/app-emacs/helm/helm-3.8.5.ebuild
new file mode 100644
index 000000000000..76b566bbf23a
--- /dev/null
+++ b/app-emacs/helm/helm-3.8.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+PATCHES="${FILESDIR}/${PN}-3.8.0-no-autoload-check.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ dobin emacs-helm.sh
+}