summaryrefslogtreecommitdiff
path: root/app-emacs/helm/helm-3.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-emacs/helm/helm-3.6.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-emacs/helm/helm-3.6.0.ebuild')
-rw-r--r--app-emacs/helm/helm-3.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/helm/helm-3.6.0.ebuild b/app-emacs/helm/helm-3.6.0.ebuild
new file mode 100644
index 000000000000..f852381e5353
--- /dev/null
+++ b/app-emacs/helm/helm-3.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-emacs/async
+ app-emacs/popup"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+ exeinto "${SITEETC}/${PN}"
+ doexe emacs-helm.sh
+}