summaryrefslogtreecommitdiff
path: root/app-emacs/god-mode/god-mode-2.18.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-07 23:37:50 +0100
commit8dfbaa8100b5c51e1de0e4e476ef5513e3ed1bdd (patch)
tree6514153552d2daad7d178ee75d47332710e2979e /app-emacs/god-mode/god-mode-2.18.0.ebuild
parent2fe5661a32d6ec0ba1d6b37cc8ae67e3f81459ec (diff)
gentoo auto-resync : 07:05:2023 - 23:37:50
Diffstat (limited to 'app-emacs/god-mode/god-mode-2.18.0.ebuild')
-rw-r--r--app-emacs/god-mode/god-mode-2.18.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/god-mode/god-mode-2.18.0.ebuild b/app-emacs/god-mode/god-mode-2.18.0.ebuild
new file mode 100644
index 000000000000..661e49b70103
--- /dev/null
+++ b/app-emacs/god-mode/god-mode-2.18.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minor mode for God-like command entering in GNU Emacs"
+HOMEPAGE="https://github.com/emacsorphanage/god-mode/"
+SRC_URI="https://github.com/emacsorphanage/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/ansi
+ app-emacs/ecukes
+ app-emacs/ecukes
+ app-emacs/f
+ )
+"
+
+DOCS=( .github/CONTRIBUTING.md .github/README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ecukes --debug --reporter spec --verbose || die "tests failed"
+}