summaryrefslogtreecommitdiff
path: root/app-emacs/ghub/ghub-3.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-15 22:05:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-15 22:05:15 +0100
commitaffa75f527bf2512b296482bd14bade15f820d6a (patch)
treeccad15ef56fd6e66c5f1a0af604048c4a3728828 /app-emacs/ghub/ghub-3.6.0.ebuild
parentbbeceee79ae8bdf53d0a494f86896a356e1cfe5f (diff)
gentoo auto-resync : 15:05:2023 - 22:05:14
Diffstat (limited to 'app-emacs/ghub/ghub-3.6.0.ebuild')
-rw-r--r--app-emacs/ghub/ghub-3.6.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/ghub/ghub-3.6.0.ebuild b/app-emacs/ghub/ghub-3.6.0.ebuild
new file mode 100644
index 000000000000..32ee8f714d36
--- /dev/null
+++ b/app-emacs/ghub/ghub-3.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minuscule client library for the Git forge APIs"
+HOMEPAGE="https://magit.vc/manual/ghub/
+ https://github.com/magit/ghub/"
+SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README.org )
+ELISP_TEXINFO="docs/ghub.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+ >=app-emacs/treepy-0.1.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ default
+
+ mv lisp/*.el . || die
+ rm ghub-pkg.el || die
+}