summaryrefslogtreecommitdiff
path: root/app-emacs/fsharp-mode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/fsharp-mode
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/fsharp-mode')
-rw-r--r--app-emacs/fsharp-mode/Manifest4
-rw-r--r--app-emacs/fsharp-mode/files/50fsharp-mode-gentoo.el4
-rw-r--r--app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild26
-rw-r--r--app-emacs/fsharp-mode/metadata.xml14
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/fsharp-mode/Manifest b/app-emacs/fsharp-mode/Manifest
new file mode 100644
index 000000000000..3df12039edec
--- /dev/null
+++ b/app-emacs/fsharp-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50fsharp-mode-gentoo.el 184 BLAKE2B 381798f016470b06d444b3187161b33aee39cc9512e53b26d925299818dd91a3bea0accef5cc8390e40216cd6db9c1db56399a3f6afe8810f49c62987e718af7 SHA512 d199454deaefaff33e55b7e3af0230de753b9700458366452372ed958bbefeca506f5ce670551e0906905291c6e6a02a5b5169c84dc48dcb459bbdc1d33e24e2
+DIST fsharp-mode-1.10_p20211229.tar.gz 78916 BLAKE2B 4cd9182c62ea0d5c7a23f2120586d4c74d16fad14762ecdb3f11a11d6c78c757b363d5c14473c10c47086c1c0e648911846fe039dfedc04fd1d84301b4aa10c5 SHA512 b02be4c8e56a2c22b7f6e6a302756278d9056e7d8b8c206c183aea5470b98610b73a3403c83e93da295d3b4d0092a4f2f1c0bdf78f701009478a3c8b1e054ab7
+EBUILD fsharp-mode-1.10_p20211229.ebuild 631 BLAKE2B 5cd87f7602cb3848768db5f1dede4b79605d680ec3fc94c0f9eafe2a31efc198686c9d31265e47035e85c262323df9a668a91d0d7cc9488ccfe7c58bf57a79ee SHA512 c81ba425604d49e1e6a5c1648d2b5bda8f10190e7d486b61949745fafc95022d7261549830723b9245998e487701bd1440f165b2f77e9d628d015f30361b0567
+MISC metadata.xml 533 BLAKE2B d0fff1e8fff09a4d096a94bc372a479a44cbb67c9aa7118ed3080690b136bd446d273b9f00a99536691f3b6bce23e46ede67d505a017b0212e459dd74300ac01 SHA512 a99fa4d18c561c0c8eb4c81a96c4cd477d2f15d8d50f4f5cb951fcafcd77e134977105c186f8ffbe7bd00db126fc218d6a006b7fdc2d29400bb0c6c05dd81b8a
diff --git a/app-emacs/fsharp-mode/files/50fsharp-mode-gentoo.el b/app-emacs/fsharp-mode/files/50fsharp-mode-gentoo.el
new file mode 100644
index 000000000000..305be955668d
--- /dev/null
+++ b/app-emacs/fsharp-mode/files/50fsharp-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'fsharp-mode "fsharp-mode"
+ "Major mode for editing fsharp code." t)
+(add-to-list 'auto-mode-alist '("\\.fs[iylx]?\\'" . fsharp-mode))
diff --git a/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild b/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild
new file mode 100644
index 000000000000..f5407ecb598a
--- /dev/null
+++ b/app-emacs/fsharp-mode/fsharp-mode-1.10_p20211229.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=b3aa4c53fc9e98648b25ad036e657632ae2fe192
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Support for the F# programming language"
+HOMEPAGE="https://github.com/fsharp/emacs-fsharp-mode/"
+SRC_URI="https://github.com/fsharp/emacs-${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${PN}-${H}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # requires Cask
+
+RDEPEND="app-emacs/s"
+BDEPEND="${RDEPEND}"
+
+DOCS=( CHANGELOG.md README.org )
+ELISP_REMOVE="eglot-fsharp.el"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/fsharp-mode/metadata.xml b/app-emacs/fsharp-mode/metadata.xml
new file mode 100644
index 000000000000..f3fd042ec1a6
--- /dev/null
+++ b/app-emacs/fsharp-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/fsharp/emacs-fsharp-mode/blob/master/CHANGELOG.md</changelog>
+ <bugs-to>https://github.com/fsharp/emacs-fsharp-mode/issues/</bugs-to>
+ <remote-id type="github">fsharp/emacs-fsharp-mode</remote-id>
+ </upstream>
+</pkgmetadata>