summaryrefslogtreecommitdiff
path: root/app-emacs/flycheck/flycheck-32_p20230305.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 06:44:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 06:44:33 +0000
commitdd5b71d2ad69f1887985ee1ca67b254e04157f73 (patch)
treee799be54f9ea7c4949c6a49c1a6f9667a7e1fef2 /app-emacs/flycheck/flycheck-32_p20230305.ebuild
parentbe14af2d51852951dbfea41913a7dd9d1190151e (diff)
gentoo auto-resync : 23:03:2023 - 06:44:33
Diffstat (limited to 'app-emacs/flycheck/flycheck-32_p20230305.ebuild')
-rw-r--r--app-emacs/flycheck/flycheck-32_p20230305.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/flycheck/flycheck-32_p20230305.ebuild b/app-emacs/flycheck/flycheck-32_p20230305.ebuild
new file mode 100644
index 000000000000..1ad096748312
--- /dev/null
+++ b/app-emacs/flycheck/flycheck-32_p20230305.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="24.3"
+
+inherit elisp
+
+DESCRIPTION="Modern on-the-fly syntax checking extension for GNU Emacs"
+HOMEPAGE="https://www.flycheck.org/"
+COMMIT="5f2ef177cb21ae8b73714575802beef04abd0f5e"
+SRC_URI="https://github.com/flycheck/flycheck/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x64-macos"
+RESTRICT="test" # TODO: wire up now that cask and ert-runner are packaged
+
+RDEPEND=">=app-emacs/dash-2.12.1
+ >=app-emacs/pkg-info-0.4"
+
+SITEFILE="50${PN}-gentoo-r1.el"
+DOCS=( README.md )
+ELISP_REMOVE="flycheck-buttercup.el flycheck-ert.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}