summaryrefslogtreecommitdiff
path: root/app-emacs/exec-path-from-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-05 21:20:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-05 21:20:55 +0100
commit2092ebe8b45cc45ad3357e2ccb2c37d5c1eaba2a (patch)
tree25c07bf0e025915c671c69127e02b8d201967e16 /app-emacs/exec-path-from-shell
parent2fc12e1ffd37b655f78c4277bd595010e18a8447 (diff)
gentoo auto-resync : 05:08:2023 - 21:20:55
Diffstat (limited to 'app-emacs/exec-path-from-shell')
-rw-r--r--app-emacs/exec-path-from-shell/Manifest2
-rw-r--r--app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/exec-path-from-shell/Manifest b/app-emacs/exec-path-from-shell/Manifest
index 4879a0bfcc6c..286212e3c5a6 100644
--- a/app-emacs/exec-path-from-shell/Manifest
+++ b/app-emacs/exec-path-from-shell/Manifest
@@ -1,4 +1,6 @@
AUX 50exec-path-from-shell-gentoo.el 84 BLAKE2B 0f3b62567ac7e3d501fe9d728cf380383f789f4c3107044747f2cfecd682f71404a49b4afa145f18e5dddc6f41247035fe72e01d6f3b362586017fdedc216c8e SHA512 42f18f03262f302c8ab28b0db1f285ab27caa19cf9acc4df4b289bd24d0e379e847022f59d5ac627ea3ebe1ba1c3f0a55ecba94d3b7f6825bcfee324983e216f
DIST exec-path-from-shell-1.12.tar.gz 17125 BLAKE2B 01440c4f484fa2e584c40961cc3a0199a812072b3a41c78833a43bd57105e677077f902ef40dbb68eeaaa84fc511d9e02d7fabdbd7c86a0bc57e1ba88aaa6888 SHA512 62f0f89f542cbf0edaf163c1dfd4fac8bb532898f8eb5a9e068a991eaddb5e6ecb1813fc76252dc2d48b42b9ab602082f612d241613002b1a37b4f7d5f5d4f3c
+DIST exec-path-from-shell-2.1.tar.gz 18673 BLAKE2B fd1d3c1cc6d7ce89eacbf9cd3cfe737a1867723dda28993ee049d91437dc8a17edf07ec1e4a121eae384deebfde934e371168ee6870e09886483cecce1bc306e SHA512 bd211756fa06115af45db6d9fb351f3affb0d59ae717643c9e4df422e63ddb780edf642d030db5b039e2759b2bfca948f7638d2dbd3ac84f3c2b8814b4a085f3
EBUILD exec-path-from-shell-1.12.ebuild 510 BLAKE2B 6b85c3b978fdd8ee26dac4d8fe501b2833f8a87e9d22334098434a7e3829383432c8b1ce1d7399ce721f56f4ee08bb1c5e9ee07406a44518b9a680145ce1430b SHA512 e785e3dd57f950d133d0d4e4db3a76c4835ebd7bf05881c719a3b91303a942562c8d63dd0c96259d6d1f976bd6aeb08d70e4ba89ceca5a93985a2d0c72b4d8da
+EBUILD exec-path-from-shell-2.1.ebuild 511 BLAKE2B 80959fd1ec50e629e1c1554c8f633eabeb0758cb428798d9bc0a30a65e8208ec2cd882eb10b9dc82582d857c2e3b7db93904b4014034888dcb3e8b1811dda9a5 SHA512 8460183e35bca490b3a151ba6500a693d4852e3de45b518940d7255f238b795e67e5ad3ed922429838dc9fac5c4ac5fab7b934c406550a03d41ae51e522e12f1
MISC metadata.xml 817 BLAKE2B 013b0baf63e956f1c9bfa234348c4ec80888321257fda7569324033c1c48418b979972d48d8bbcfb83d75cfb44fae9a0cd484bd1e7e7a65c7fec58542aeccd7e SHA512 78d256c67f5e15e1895e13ab57fbe8d80897184f2aa04698df4a4de60ab0da5dbbb59c65f3696e2e548456eee249550bffdda45025abd3844c0fbb6c6886cb02
diff --git a/app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild b/app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild
new file mode 100644
index 000000000000..28ccd181049b
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/exec-path-from-shell-2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Ensure environment variables inside Emacs are the same as in shell"
+HOMEPAGE="https://github.com/purcell/exec-path-from-shell/"
+SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}