summaryrefslogtreecommitdiff
path: root/app-emacs/emms/emms-4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-31 15:47:53 +0000
commitd950fa39dbe16d164ed0cb8e3036fd5d0d896a4c (patch)
tree04f92d5d1070a7aedb970ce4539dc6d60253c4df /app-emacs/emms/emms-4.3.ebuild
parentbd7908c6630f38067350d396ac5d18c3cc2434a0 (diff)
gentoo resync : 31.10.2017
Diffstat (limited to 'app-emacs/emms/emms-4.3.ebuild')
-rw-r--r--app-emacs/emms/emms-4.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/emms/emms-4.3.ebuild b/app-emacs/emms/emms-4.3.ebuild
new file mode 100644
index 000000000000..1aacf114f268
--- /dev/null
+++ b/app-emacs/emms/emms-4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="media-libs/taglib"
+RDEPEND="${DEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo doc/emms.info*
+ dobin src/emms-print-metadata
+ doman emms-print-metadata.1
+ dodoc AUTHORS ChangeLog NEWS README THANKGNU
+}