summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-openrc/emacs-openrc-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /app-emacs/emacs-openrc/emacs-openrc-1.0.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'app-emacs/emacs-openrc/emacs-openrc-1.0.0.ebuild')
-rw-r--r--app-emacs/emacs-openrc/emacs-openrc-1.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/emacs-openrc/emacs-openrc-1.0.0.ebuild b/app-emacs/emacs-openrc/emacs-openrc-1.0.0.ebuild
new file mode 100644
index 000000000000..d93955ee5cfb
--- /dev/null
+++ b/app-emacs/emacs-openrc/emacs-openrc-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="OpenRC integration for GNU Emacs"
+HOMEPAGE="https://gitweb.gentoo.org/proj/emacs-openrc.git"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitweb.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}