summaryrefslogtreecommitdiff
path: root/app-emacs/emacs-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-25 05:42:53 +0100
commit5c636a121a9064a4373d06b60d49a6f5d67c0e2f (patch)
tree8e5c8c582e12cb579ac94bdaafcd00282252a50d /app-emacs/emacs-common
parentb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (diff)
gentoo auto-resync : 25:07:2023 - 05:42:52
Diffstat (limited to 'app-emacs/emacs-common')
-rw-r--r--app-emacs/emacs-common/Manifest4
-rw-r--r--app-emacs/emacs-common/emacs-common-1.9.ebuild112
-rw-r--r--app-emacs/emacs-common/metadata.xml2
3 files changed, 117 insertions, 1 deletions
diff --git a/app-emacs/emacs-common/Manifest b/app-emacs/emacs-common/Manifest
index a1fab9770db9..7672a304cd9d 100644
--- a/app-emacs/emacs-common/Manifest
+++ b/app-emacs/emacs-common/Manifest
@@ -1,3 +1,5 @@
DIST emacs-common-1.8.tar.xz 61352 BLAKE2B 084cf06c03db231c92d0074a2e633d209257941b2840c2c745462050e694756f97679c7078357d9eab7b2fcfb85b00ab390d65254ddd106d0ef1a1fd723b2c4c SHA512 85c4b826c0691fd24f260750f4c3f9ecc3b59d11b4dafcae608e1a2546c064b240084974962b0727ac8183b8f5b0891cf47add901461f77ee275a129341b2b13
+DIST emacs-common-1.9.tar.xz 61812 BLAKE2B 6a87dae71120c2b41a4918dc788f7baa161eb0cc2b895a39e721330a6151a888cd9d930f93ac840557d3766847a7eb5ff8907d2fdde2c897a296887c0a5cf8c2 SHA512 b2e2df57a83548aeb7f7271a7d0b9ca27086d0c0ec80b6aa354016938ece70e8d9058214e7a813ec491bd67a61df8afbe4b55081b68a109ce527ba6cdba7e891
EBUILD emacs-common-1.8.ebuild 2859 BLAKE2B e13f40d2f91020e5836bd6d7dbedd61ffb09a2bf0e709155521078c4687cbc6bd318b4b6ba23d94c311e37679abfc439260fd93069fefc35b37f355d84ed92c8 SHA512 aff259937706ed1d0d9b01a0f7925cdc439060954c6561ecf4c9ea8876b0aa126037c674c14d4d1224e299a1712607565bf5ba2454e713db1f75f8394597c526
-MISC metadata.xml 440 BLAKE2B 6a1645bfaa43e74316908aeadd3920b9279ae9b94cb0c9a231b020e16dcd63521aed390d76e00bdc11f10045ff29d02566666b17b826fab2a79bd0e2ec69176d SHA512 7654fa1d91f82e1f9cfdaf7f0e5f8f270fd22e96d63736979e64a018b3a55a5874f838b6dfca07191afda50b46e4fe9f8a4a3db7080ffbb16ce5715852bb967d
+EBUILD emacs-common-1.9.ebuild 3157 BLAKE2B cf4f9a9d65354b0393e4aa7f6d03513aa47866e42f8824db7b418cec5923827f1b16e81bfa5a14f2eb8e49bd9a287397bbc79dd727a82f4e510cd012132ca67f SHA512 a9e0f0966142fc13e6dba43502c7d9708f5295855e4a9f85fbae340dfbc17005334b816ccb234d65fa2a0ce37ebd05767153943e8134d51bbce2f31a777bee34
+MISC metadata.xml 535 BLAKE2B 6c6c5bb8ce0585a2bcd37f80f6426f1e4304715f142a36d186643f9f69054fc49f889847d1d76d34537152dc9d8310a066bce1ea40b2ff7c30ee4c2dcf3b185b SHA512 0a200530dc27ea2a6ca1860d70964027d9bc748b19459639f3a946ffc4f83c965d339683a1ceb1f9cb03212a1877dc1ca51a2a1dfd1c8c9fc814aff67ad177c1
diff --git a/app-emacs/emacs-common/emacs-common-1.9.ebuild b/app-emacs/emacs-common/emacs-common-1.9.ebuild
new file mode 100644
index 000000000000..60ef21b66c71
--- /dev/null
+++ b/app-emacs/emacs-common/emacs-common-1.9.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common desktop gnome2-utils xdg-utils readme.gentoo-r1
+
+DESCRIPTION="Common files needed by all GNU Emacs versions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="games gsettings gui"
+
+DEPEND="games? ( acct-group/gamestat )"
+RDEPEND="!=app-editors/emacs-29.1_rc1-r0
+ ${DEPEND}
+ gui? ( gsettings? ( dev-libs/glib ) )"
+PDEPEND=">=app-editors/emacs-23.1:*"
+
+src_install() {
+ insinto "${SITELISP}"
+ sed -e "s:@libdir@:$(get_libdir):g" subdirs.el.in | newins - subdirs.el
+ assert
+ newins site-gentoo.el{,.orig}
+
+ keepdir /etc/emacs
+ insinto /etc/emacs
+ doins site-start.el
+
+ if use games; then
+ keepdir /var/games/emacs
+ fowners 0:gamestat /var/games/emacs
+ fperms g+w /var/games/emacs
+ fi
+
+ if use gui; then
+ local i
+ domenu emacs.desktop emacsclient.desktop
+
+ pushd icons || die
+ newicon sink.png emacs-sink.png
+ newicon emacs25_48.png emacs.png
+ for i in 16 24 32 48 128; do
+ [[ ${i} -le 48 ]] && newicon -s ${i} emacs22_${i}.png emacs22.png
+ newicon -s ${i} emacs23_${i}.png emacs23.png
+ newicon -s ${i} emacs25_${i}.png emacs.png
+ done
+ doicon -s scalable emacs23.svg
+ newicon -s scalable emacs25.svg emacs.svg
+ popd
+
+ if use gsettings; then
+ insinto /usr/share/glib-2.0/schemas
+ doins org.gnu.emacs.defaults.gschema.xml
+ fi
+ fi
+
+ DOC_CONTENTS="All site initialisation for Gentoo-installed packages is
+ added to ${SITELISP}/site-gentoo.el. In order for this site
+ initialisation to be loaded for all users automatically, a default
+ site startup file /etc/emacs/site-start.el is installed. You are
+ responsible for maintenance of this file.
+ \n\nAlternatively, individual users can add the following command:
+ \n\n(require 'site-gentoo)
+ \n\nto their ~/.emacs initialisation files, or, for greater
+ flexibility, users may load single package-specific initialisation
+ files from the ${SITELISP}/site-gentoo.d/ directory."
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ # make sure that site-gentoo.el exists since site-start.el requires it
+ if [[ ! -f ${ED}${SITELISP}/site-gentoo.el ]]; then #554518
+ mv "${ED}${SITELISP}"/site-gentoo.el{.orig,} || die
+ fi
+ if [[ -d ${EROOT}${SITELISP} ]]; then
+ elisp-site-regen
+ cp "${EROOT}${SITELISP}/site-gentoo.el" "${ED}${SITELISP}/" || die
+ fi
+
+ if use games; then
+ local f
+ for f in /var/games/emacs/{snake,tetris}-scores; do
+ if [[ -e ${EROOT}${f} ]]; then
+ cp "${EROOT}${f}" "${ED}${f}" || die
+ fi
+ touch "${ED}${f}" || die
+ chgrp gamestat "${ED}${f}" || die
+ chmod g+w "${ED}${f}" || die
+ done
+ fi
+}
+
+pkg_postinst() {
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ use gsettings && gnome2_schemas_update
+ fi
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ if use gui; then
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ use gsettings && gnome2_schemas_update
+ fi
+}
diff --git a/app-emacs/emacs-common/metadata.xml b/app-emacs/emacs-common/metadata.xml
index 866f5b95b83c..8c804e6f4e3d 100644
--- a/app-emacs/emacs-common/metadata.xml
+++ b/app-emacs/emacs-common/metadata.xml
@@ -8,6 +8,8 @@
<stabilize-allarches/>
<use>
<flag name="games">Support shared score files for games</flag>
+ <flag name="gsettings">Install schema file for gsettings
+ (<pkg>dev-libs/glib</pkg>)</flag>
</use>
<upstream>
<remote-id type="gentoo">proj/emacs-tools</remote-id>