summaryrefslogtreecommitdiff
path: root/app-emacs/elscreen/elscreen-1.4.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/elscreen/elscreen-1.4.6-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/elscreen/elscreen-1.4.6-r1.ebuild')
-rw-r--r--app-emacs/elscreen/elscreen-1.4.6-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/elscreen/elscreen-1.4.6-r1.ebuild b/app-emacs/elscreen/elscreen-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..c2673da73b4c
--- /dev/null
+++ b/app-emacs/elscreen/elscreen-1.4.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit elisp
+
+DESCRIPTION="Frame configuration management for GNU Emacs modelled after GNU Screen"
+HOMEPAGE="http://www.morishima.net/~naoto/j/software/elscreen/"
+SRC_URI="ftp://ftp.morishima.net/pub/morishima.net/naoto/ElScreen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ~ia64 ~ppc ~ppc64 sparc x86"
+IUSE=""
+
+DEPEND=">=app-emacs/apel-10.8-r1"
+RDEPEND="${DEPEND}"
+
+ELISP_PATCHES="${PN}-1.4.6-void-variable-argi.patch ${PN}-1.4.6-emacs-24.patch"
+
+SITEFILE=50${PN}-gentoo.el
+DOCS="ChangeLog README"
+
+pkg_postinst() {
+ elisp-site-regen
+
+ echo
+ elog "ElScreen modifies standard Emacs keybindings and is therefore"
+ elog "no longer loaded from site-gentoo.el. Add the line"
+ elog " (require 'elscreen)"
+ elog "to your ~/.emacs file to enable it on Emacs startup."
+}