summaryrefslogtreecommitdiff
path: root/app-emacs/eldev/eldev-1.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /app-emacs/eldev/eldev-1.8.2.ebuild
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'app-emacs/eldev/eldev-1.8.2.ebuild')
-rw-r--r--app-emacs/eldev/eldev-1.8.2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-emacs/eldev/eldev-1.8.2.ebuild b/app-emacs/eldev/eldev-1.8.2.ebuild
deleted file mode 100644
index 3f11b2985b3e..000000000000
--- a/app-emacs/eldev/eldev-1.8.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp
-
-DESCRIPTION="Emacs Lisp Development Tool"
-HOMEPAGE="https://emacs-eldev.github.io/eldev/
- https://github.com/doublep/eldev/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/doublep/${PN}.git"
-else
- SRC_URI="https://github.com/doublep/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
- KEYWORDS="amd64 ~arm ~ppc64 ~riscv ~x86"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-ELISP_REMOVE="test/doctor.el"
-
-DOCS=( README.adoc )
-SITEFILE="50${PN}-gentoo.el"
-
-src_test() {
- ELDEV_LOCAL="${S}" "./bin/${PN}" test
-}
-
-src_install() {
- elisp_src_install
- dobin "./bin/${PN}"
-
- # NOTICE: If ELDEV_LOCAL is defined Eldev will use it
- # to load up it's components,
- # if it is not it will bootstrap itself from network
- # always check if it uses installed Emacs Lisp files.
- # Also, do not forget to run `env-update` & reopen your shell.
- # https://github.com/doublep/eldev#influential-environment-variables
- echo "ELDEV_LOCAL=${SITELISP}/${PN}" >> "${T}/99${PN}" || die
- doenvd "${T}/99${PN}"
-}
-
-pkg_postinst() {
- elisp_pkg_postinst
-
- ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
- ewarn "to use Eldev in a shell before logging out (or restarting"
- ewarn "your login manager)."
-}