summaryrefslogtreecommitdiff
path: root/app-emacs/eldev/eldev-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 19:15:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 19:15:12 +0000
commitb3e456d42287ef73c7ff48148d18a9ea8fb8debf (patch)
tree1c9ad46437b76c8af060cd54ff3ceb0f8678b6ce /app-emacs/eldev/eldev-1.3.ebuild
parent7de40ae3e1ba40671bc9aac9ebbf3f42952a036b (diff)
gentoo auto-resync : 26:11:2022 - 19:15:12
Diffstat (limited to 'app-emacs/eldev/eldev-1.3.ebuild')
-rw-r--r--app-emacs/eldev/eldev-1.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/eldev/eldev-1.3.ebuild b/app-emacs/eldev/eldev-1.3.ebuild
new file mode 100644
index 000000000000..3f35959f7270
--- /dev/null
+++ b/app-emacs/eldev/eldev-1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp Development Tool"
+HOMEPAGE="https://github.com/doublep/eldev/"
+SRC_URI="https://github.com/doublep/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( README.adoc )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ELDEV_LOCAL="${S}" ./bin/${PN} test
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+
+ # NOTICE: If ELDEV_LOCAL is defined Eldev will use it
+ # to load up it's components,
+ # if it is not it will bootstrap itself from network
+ # always check if it uses installed Emacs Lisp files.
+ # Also, do not forget to run `env-update` & reopen your shell.
+ # https://github.com/doublep/eldev#influential-environment-variables
+ echo "ELDEV_LOCAL=${SITELISP}/${PN}" >> "${T}"/99${PN} || die
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use Eldev in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}