summaryrefslogtreecommitdiff
path: root/app-emacs/eglot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/eglot
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/eglot')
-rw-r--r--app-emacs/eglot/Manifest4
-rw-r--r--app-emacs/eglot/eglot-1.8.ebuild28
-rw-r--r--app-emacs/eglot/metadata.xml4
3 files changed, 35 insertions, 1 deletions
diff --git a/app-emacs/eglot/Manifest b/app-emacs/eglot/Manifest
index 76a03281f966..cfc066c33410 100644
--- a/app-emacs/eglot/Manifest
+++ b/app-emacs/eglot/Manifest
@@ -1,4 +1,6 @@
AUX 50eglot-gentoo.el 76 BLAKE2B 0f41a5837bd485730c10074ca5c2dba963cf69b96043f3439e9f1e7a41d468cd706e974c7d7b312e51db98d6e7573b4ec284603998c2fe1de05f86496c3ec0cd SHA512 6c06dfa72ac6122c82dc59bb672f796ae86e71548babb2bb0dc2b00e58050e65b51e13aab279d5f3e7f1283ca2e0a64c7d34a55b412c2d81fc58fc495864c8c4
DIST eglot-1.6.tar.gz 288078 BLAKE2B a2214d216d0eeaca32d974c6686696dfcf141b3384741bc8cce0d02abb508eb5713933bc227d12a07f4b87fc34601431845b1b8e519538ae04ecc74b24db4004 SHA512 51227c8e2b0a1dd9a63ededbea592f01616ff728c34c330400c078212fef3f3e747e6dd30ba312523cbe60c7ea663a7af9d83300210cf331ea6162d2db5c7e41
+DIST eglot-1.8.tar.gz 302450 BLAKE2B 7247b11adaf9a65a2e071ca17b55038fe85f5842fb4155b44dbfa82bae5774e4cd2f7a5557d40cb1a7ab7f554233f15abe297e10568a1630b464ab6a600d978f SHA512 0295eff6dfbbf9d7a82349b8e5ed9e7dad700f2f0bfcab879d906e30bfbb4d28b8779fd9076108ac9b1594a60ca5e30c5035e2f8ceae44add99c28a843027609
EBUILD eglot-1.6.ebuild 670 BLAKE2B a1ca6c70ae3da6d338162f14bb0e778ef8eab25545622f1fcfc0e38df1df31588194cd3e7b8988c33dc39373b2c4bdeaad251cbd3e551ff16273936f33fc8d1b SHA512 77c26b1afba7513e8e3bf286003fd0a82971762b36cf78dfcda6101a03d043201c9d2b4e27a9773043ac62fe2d64c6bf25b74efc946d0b1f639219c928343ef7
-MISC metadata.xml 573 BLAKE2B cf91f12d06d2e0894d18c725eeef788341d8b1beb48eed71d7da0e31ac45e91e5df4e452613699dbed5f4da1e33c12a138296e983a51203f81c173db741001e2 SHA512 6d869d7cdd14557f758dce45df93822800577226518db4afc1ac9efbae4d97f99b77ef45afaf90f7b248ba5de76ec51ee2231ddea8095ddb09bf40eb0a378442
+EBUILD eglot-1.8.ebuild 670 BLAKE2B a1ca6c70ae3da6d338162f14bb0e778ef8eab25545622f1fcfc0e38df1df31588194cd3e7b8988c33dc39373b2c4bdeaad251cbd3e551ff16273936f33fc8d1b SHA512 77c26b1afba7513e8e3bf286003fd0a82971762b36cf78dfcda6101a03d043201c9d2b4e27a9773043ac62fe2d64c6bf25b74efc946d0b1f639219c928343ef7
+MISC metadata.xml 701 BLAKE2B 436bc9f2720fad7cc3a7bcf9597a820317617ad7522e72c05417d6b9e1cb9c37d171ce5e24741b5730ab6708a0bcafacc8f41df3d4108926868887dc6ee25df3 SHA512 457dec4f625c37429917085c187e7c21ad1155217f79980033a7c0ecf62da941d340433ccbcbd5ae36a028aed7ab0cd1204e74985e36844e31829dab288c4fa8
diff --git a/app-emacs/eglot/eglot-1.8.ebuild b/app-emacs/eglot/eglot-1.8.ebuild
new file mode 100644
index 000000000000..913bb955411f
--- /dev/null
+++ b/app-emacs/eglot/eglot-1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="26.1"
+
+inherit elisp
+
+DESCRIPTION="A minimal Emacs LSP client"
+HOMEPAGE="https://github.com/joaotavora/eglot"
+SRC_URI="https://github.com/joaotavora/eglot/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+# test requires internet connection to install several language servers, one of which
+# is not packaged
+RESTRICT="test"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_REMOVE="eglot-tests.el"
+DOCS=( README.md NEWS.md )
+
+src_install() {
+ elisp-make-autoload-file "${S}"/${PN}-autoload.el "${S}"/
+ elisp_src_install
+}
diff --git a/app-emacs/eglot/metadata.xml b/app-emacs/eglot/metadata.xml
index 4d327b888ffc..d9638f7e735e 100644
--- a/app-emacs/eglot/metadata.xml
+++ b/app-emacs/eglot/metadata.xml
@@ -9,6 +9,10 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
<upstream>
<remote-id type="github">joaotavora/eglot</remote-id>
<doc>https://github.com/joaotavora/eglot/blob/master/README.md</doc>