summaryrefslogtreecommitdiff
path: root/app-emacs/eglot/eglot-1.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /app-emacs/eglot/eglot-1.11.ebuild
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'app-emacs/eglot/eglot-1.11.ebuild')
-rw-r--r--app-emacs/eglot/eglot-1.11.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/eglot/eglot-1.11.ebuild b/app-emacs/eglot/eglot-1.11.ebuild
new file mode 100644
index 000000000000..4c3f5fa8f297
--- /dev/null
+++ b/app-emacs/eglot/eglot-1.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.3
+
+inherit elisp
+
+DESCRIPTION="A minimal Emacs LSP client"
+HOMEPAGE="https://github.com/joaotavora/eglot/
+ https://elpa.gnu.org/packages/eglot.html"
+SRC_URI="https://dev.gentoo.org/~xgqt/distfiles/repackaged/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/external-completion"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp-make-autoload-file "${S}"/${PN}-autoload.el "${S}"/
+ elisp_src_install
+}