summaryrefslogtreecommitdiff
path: root/app-emacs/ef-themes/ef-themes-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
commit783da4542a9c3e0e1ec703644212707cde610679 (patch)
tree3e0cf56ac37ddf9d5fdc6ff0ced9135b1c7fc5e0 /app-emacs/ef-themes/ef-themes-9999.ebuild
parentd0041c590ed45bbfeae458ea926e36bc64e41dd7 (diff)
gentoo auto-resync : 10:09:2023 - 22:36:45
Diffstat (limited to 'app-emacs/ef-themes/ef-themes-9999.ebuild')
-rw-r--r--app-emacs/ef-themes/ef-themes-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/ef-themes/ef-themes-9999.ebuild b/app-emacs/ef-themes/ef-themes-9999.ebuild
new file mode 100644
index 000000000000..e12280ff911b
--- /dev/null
+++ b/app-emacs/ef-themes/ef-themes-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Colourful and legible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/ef-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md README.org contrast-ratios.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+
+ elisp_src_compile
+ elisp-make-autoload-file
+}