summaryrefslogtreecommitdiff
path: root/app-emacs/edb/edb-1.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/edb/edb-1.31.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/edb/edb-1.31.ebuild')
-rw-r--r--app-emacs/edb/edb-1.31.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/edb/edb-1.31.ebuild b/app-emacs/edb/edb-1.31.ebuild
new file mode 100644
index 000000000000..db5282db439e
--- /dev/null
+++ b/app-emacs/edb/edb-1.31.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="EDB, The Emacs Database"
+HOMEPAGE="http://www.gnuvola.org/software/edb/
+ http://www.emacswiki.org/emacs/EmacsDataBase"
+SRC_URI="http://www.gnuvola.org/software/edb/${P}.tar.gz"
+
+LICENSE="GPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+ELISP_PATCHES="${P}-skram-path.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake -j1 \
+ sitelisp="${ED}${SITELISP}" \
+ infodir="${ED}/usr/share/info" \
+ install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README THANKS TODO doc/refcard.ps
+ dodoc -r examples
+}