summaryrefslogtreecommitdiff
path: root/app-emacs/ebuild-mode/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/ebuild-mode/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/ebuild-mode/files')
-rw-r--r--app-emacs/ebuild-mode/files/50ebuild-mode-gentoo-1.31.el13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo-1.31.el b/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo-1.31.el
new file mode 100644
index 000000000000..5a096923c4c5
--- /dev/null
+++ b/app-emacs/ebuild-mode/files/50ebuild-mode-gentoo-1.31.el
@@ -0,0 +1,13 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ebuild-mode "ebuild-mode"
+ "Major mode for Portage .ebuild and .eclass files." t)
+(autoload 'gentoo-newsitem-mode "gentoo-newsitem-mode"
+ "Major mode for Gentoo GLEP 42 news items." t)
+
+(add-to-list 'auto-mode-alist '("\\.\\(ebuild\\|eclass\\)\\'" . ebuild-mode))
+(add-to-list 'auto-mode-alist
+ '("/[0-9]\\{4\\}-[01][0-9]-[0-3][0-9]-.+\\.[a-z]\\{2\\}\\.txt\\'"
+ . gentoo-newsitem-mode))
+(add-to-list 'interpreter-mode-alist '("openrc-run" . sh-mode))
+(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode))
+(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8)