summaryrefslogtreecommitdiff
path: root/app-emacs/doom-modeline/doom-modeline-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-20 05:59:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-20 05:59:19 +0100
commitdcf9ac80d0667a18496506842a8903ba5dab2fc7 (patch)
tree2b00642cd6bdbd7de71159350f01b424ffc37420 /app-emacs/doom-modeline/doom-modeline-3.4.0.ebuild
parentf7e94be7540157809ed892278b6765c368a5a912 (diff)
gentoo auto-resync : 20:04:2023 - 05:59:19
Diffstat (limited to 'app-emacs/doom-modeline/doom-modeline-3.4.0.ebuild')
-rw-r--r--app-emacs/doom-modeline/doom-modeline-3.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/doom-modeline/doom-modeline-3.4.0.ebuild b/app-emacs/doom-modeline/doom-modeline-3.4.0.ebuild
new file mode 100644
index 000000000000..6740287569c1
--- /dev/null
+++ b/app-emacs/doom-modeline/doom-modeline-3.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Fancy and fast mode-line for Emacs inspired by minimalism design"
+HOMEPAGE="https://seagle0128.github.io/doom-modeline/
+ https://github.com/seagle0128/doom-modeline/"
+SRC_URI="https://github.com/seagle0128/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/all-the-icons
+ app-emacs/compat
+ app-emacs/shrink-path
+"
+BDEPEND="${RDEPEND}"
+
+elisp-enable-tests ert test
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}