summaryrefslogtreecommitdiff
path: root/app-emacs/desktop+/desktop+-0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/desktop+/desktop+-0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/desktop+/desktop+-0.2.ebuild')
-rw-r--r--app-emacs/desktop+/desktop+-0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/desktop+/desktop+-0.2.ebuild b/app-emacs/desktop+/desktop+-0.2.ebuild
new file mode 100644
index 000000000000..adf858b1a86d
--- /dev/null
+++ b/app-emacs/desktop+/desktop+-0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp
+
+DESCRIPTION="desktop+ extends standard desktop module"
+HOMEPAGE="https://github.com/ffevotte/desktop-plus"
+SRC_URI="https://github.com/ffevotte/desktop-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+RDEPEND="app-emacs/dash app-emacs/f"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/desktop-plus-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README.md"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}