summaryrefslogtreecommitdiff
path: root/app-emacs/dashboard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-emacs/dashboard
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-emacs/dashboard')
-rw-r--r--app-emacs/dashboard/Manifest5
-rw-r--r--app-emacs/dashboard/dashboard-1.8.0_pre20220406.ebuild38
-rw-r--r--app-emacs/dashboard/files/50dashboard-gentoo.el3
-rw-r--r--app-emacs/dashboard/files/dashboard-dashboard-widgets.el-banners.patch12
-rw-r--r--app-emacs/dashboard/metadata.xml14
5 files changed, 72 insertions, 0 deletions
diff --git a/app-emacs/dashboard/Manifest b/app-emacs/dashboard/Manifest
new file mode 100644
index 000000000000..1e11444803fd
--- /dev/null
+++ b/app-emacs/dashboard/Manifest
@@ -0,0 +1,5 @@
+AUX 50dashboard-gentoo.el 130 BLAKE2B e6bbe3301308c1f6676a08586bb50f50f41bdc8e6dcace0b18d27ff6a43517a855c33283d13b5220f05c85bdb843cd6987718b60a58105bc722ce9b4d27eed0c SHA512 64fd0f460b8735de0c833e38e86a22401397cc017e99df22afe11037b0096b871b0fc8423706465478e0bcda8ce34d815f2de47c8ecdacf70ece9f0336b5e217
+AUX dashboard-dashboard-widgets.el-banners.patch 352 BLAKE2B cb6b45429bffe3534e5ed218eb5f69fc4e29587ceadfb665d7385b0169c9aaa6b6ec5acf3fa219f0e08285cb835ae35f92c38a6b9df24ecab62e8e3bb6590068 SHA512 c35592d938afcf6996259a4e0d9043afdfa51af67cea588b119eba669413117ecd88087fc5c9ca268087a2d5d6668d27e06f54995ca62c67f48dfb2996fa72e4
+DIST dashboard-1.8.0_pre20220406.tar.gz 191442 BLAKE2B 8b105d8ed9b31e7439cc55b85c9e0bb46739fcb26f9e1e605492a552cbcfe9799794be6239b6c622bfbfc2f850d20f2944f759010eb502bcb75edb570ae7e5b8 SHA512 b3b714bbee034fecbf1172dccd5eebc38373c11a510c532a7b9ba31cac79daafe7e9ccf7c5e622abbdb44817c966f100ec4f7a447e8b0370f9d7e66ff55e45ca
+EBUILD dashboard-1.8.0_pre20220406.ebuild 953 BLAKE2B 1d572847f8e3432a4f30949ed4cd739a16b60e7622c30e1f025f355299b3dacb71399b37a8ea5be953d76585acb729f587cabc0306bf6fd5a7cc96acff8f5484 SHA512 c6654c6b5dd0815c272ebf0909b44c2bb32d13b9d20f5d3750ed7ed3cd350835010dc0e2cb48041209ac21ee16c1d0b3c8cce7332f20c0a3867d6e3cecc7b808
+MISC metadata.xml 564 BLAKE2B fd3eea99e99ad926d6600df608f5b04f3a44a690a10ffa74a32314838360c637fb618bda7d600236d6ce2eec59a11cac37231941334da756e893e9561acfc933 SHA512 56071ea793b85ba75b1139f4f3f43b69a418fad2ed5b2c23469f281deb47c2b09a1beefa3c13281ee2a001999823d955f600e29100885747f55544ce5af63ee9
diff --git a/app-emacs/dashboard/dashboard-1.8.0_pre20220406.ebuild b/app-emacs/dashboard/dashboard-1.8.0_pre20220406.ebuild
new file mode 100644
index 000000000000..88cc08a233ff
--- /dev/null
+++ b/app-emacs/dashboard/dashboard-1.8.0_pre20220406.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=69f98f5a89451c0881d0abb34ad57dd71616006a
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Extensible Emacs dashboard, with sections for bookmarks, projects, agenda and more"
+HOMEPAGE="https://github.com/emacs-dashboard/emacs-dashboard/"
+SRC_URI="https://github.com/emacs-dashboard/emacs-${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${PN}-${H}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # tests not in the repository, require "Eask"
+
+DOCS=( CHANGELOG.md README.org etc )
+PATCHES=( "${FILESDIR}"/${PN}-dashboard-widgets.el-banners.patch )
+
+ELISP_REMOVE=( .dir-locals.el )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i dashboard-widgets.el || die
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}"/${PN}
+ doins -r banners
+}
diff --git a/app-emacs/dashboard/files/50dashboard-gentoo.el b/app-emacs/dashboard/files/50dashboard-gentoo.el
new file mode 100644
index 000000000000..99dbca09ee09
--- /dev/null
+++ b/app-emacs/dashboard/files/50dashboard-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'dashboard-setup-startup-hook "dashboard"
+ "Setup post initialization hooks." t)
diff --git a/app-emacs/dashboard/files/dashboard-dashboard-widgets.el-banners.patch b/app-emacs/dashboard/files/dashboard-dashboard-widgets.el-banners.patch
new file mode 100644
index 000000000000..9ce24c2d9bd6
--- /dev/null
+++ b/app-emacs/dashboard/files/dashboard-dashboard-widgets.el-banners.patch
@@ -0,0 +1,12 @@
+index 494ea0d..1ae6ebb 100644
+--- a/dashboard-widgets.el
++++ b/dashboard-widgets.el
+@@ -136,7 +136,7 @@ preserved."
+ :group 'dashboard)
+
+ (defconst dashboard-banners-directory
+- (concat (file-name-directory (locate-library "dashboard")) "banners/")
++ "@SITEETC@/banners/"
+ "Default banner directory.")
+
+ (defconst dashboard-banner-official-png
diff --git a/app-emacs/dashboard/metadata.xml b/app-emacs/dashboard/metadata.xml
new file mode 100644
index 000000000000..dbd2fb8bfbca
--- /dev/null
+++ b/app-emacs/dashboard/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/emacs-dashboard/emacs-dashboard/master/CHANGELOG.md</changelog>
+ <bugs-to>https://github.com/emacs-dashboard/emacs-dashboard/issues/</bugs-to>
+ <remote-id type="github">emacs-dashboard/emacs-dashboard</remote-id>
+ </upstream>
+</pkgmetadata>