summaryrefslogtreecommitdiff
path: root/app-emacs/crypt++
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/crypt++
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/crypt++')
-rw-r--r--app-emacs/crypt++/Manifest6
-rw-r--r--app-emacs/crypt++/crypt++-2.92.ebuild17
-rw-r--r--app-emacs/crypt++/crypt++-2.94_pre20080430.ebuild17
-rw-r--r--app-emacs/crypt++/files/50crypt++-gentoo.el2
-rw-r--r--app-emacs/crypt++/metadata.xml17
5 files changed, 59 insertions, 0 deletions
diff --git a/app-emacs/crypt++/Manifest b/app-emacs/crypt++/Manifest
new file mode 100644
index 000000000000..216e11547624
--- /dev/null
+++ b/app-emacs/crypt++/Manifest
@@ -0,0 +1,6 @@
+AUX 50crypt++-gentoo.el 57 BLAKE2B 5e62ba7f3832ceed74ecbc3680442bfe260f2a7244416016cbce58e6105aabe0d30747b57671804d8c38b75fa90fc53db3d0497108507f1859f265925c2492ab SHA512 3e7407aff3b5639f78eba1af624a370316488b33e824138a55965537eebbdeb929a4b65d8f9cef23f414fa8509abf19e951eb71b8f1ad2e9b809a5590c15fbfc
+DIST crypt++-2.94_pre20080430.el.bz2 28692 BLAKE2B 2b7f227b87b16fc6b3fdfdb62059a55c70ee95008a144bc7ec0e8c3f5699ec2ba14989b8ae2da3fa7c4bb56070eac7ea1755caddfd27e6c2a53e8a62068ca6cc SHA512 8e142840f8e2db4688e9ce4432ee14db4225899a88a35dea3e371f829ccfc24faa34c607517e344e7706bf75126d758b0490dd5324efa43d4649de127076a5ce
+DIST crypt++el_2.92.orig.tar.gz 34251 BLAKE2B 579d44269ec84a9548e9e4cb845601027be3862f2f56a2ab99b3c46155f6839c7e5b9426c97ea12ac936df62fb533f5424de8afc7df6983f339eb166b6df6486 SHA512 d3abf169f60c3d1a270149b800d96f7132ebeb99b6952858b81cb2c05ffdce30f6c46f75723490731c47e7eb44515554e012da98351bbd9f9127dcba8453e389
+EBUILD crypt++-2.92.ebuild 447 BLAKE2B becd2bd3c43b622e13590a021252bca5ece53dfd1e0e3510f52f8977e094ef7b37fc3034d1b6e3e2270813a704473cb000e9901731dc0ae40d0af154089ba109 SHA512 c23ad4ce87ecf9954b93df6ab1d3cb8fa1a5c6c389867ec72f45b00d2c84bfcea4797ecb4b24345362083b4be8256cb51b4eef88cee267f988a754600f4cbaa9
+EBUILD crypt++-2.94_pre20080430.ebuild 505 BLAKE2B de2acd1603001914b78c43b906268b5085743918788c8eaaa7bae8d23ece9c32dc89002e3f2b873bdf296da0948b7b955417281d687d71df3856c9c44b8f560b SHA512 c7608028665138365b308a9d146f251f47bee2d82ea67ff6a324c8be8248796da1b8988c1e5670376088eb3dabb4a5aab00654ed1706feedd0faf2bee4b1992f
+MISC metadata.xml 759 BLAKE2B 493432cd932a42c0a22d3bfbd2d93bcfa13c1605e1f35e613e1f400bd06803473a0d9a4442bc80926e27661b046523606b3b63da750a58c54f06ac4523bfee12 SHA512 212f1940a5100f7d8f94470512c25e8ddd2f0fbf6089a650d7a18fe43cc525cbdf44e3dd905f4f5af798328a31edc2e76f39285d49c4f085c47ae5bd18a29f67
diff --git a/app-emacs/crypt++/crypt++-2.92.ebuild b/app-emacs/crypt++/crypt++-2.92.ebuild
new file mode 100644
index 000000000000..f28ba6418631
--- /dev/null
+++ b/app-emacs/crypt++/crypt++-2.92.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Handle all sorts of compressed and encrypted files"
+HOMEPAGE="https://www.emacswiki.org/emacs/CryptPlusPlus"
+SRC_URI="mirror://debian/pool/main/c/crypt++el/crypt++el_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+
+S="${WORKDIR}/${PN}el-${PV}"
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/crypt++/crypt++-2.94_pre20080430.ebuild b/app-emacs/crypt++/crypt++-2.94_pre20080430.ebuild
new file mode 100644
index 000000000000..b534e837c5d5
--- /dev/null
+++ b/app-emacs/crypt++/crypt++-2.94_pre20080430.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Handle all sorts of compressed and encrypted files"
+HOMEPAGE="https://www.emacswiki.org/emacs/CryptPlusPlus"
+# snapshot from http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/xemacs-packages/os-utils/crypt.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/crypt++/files/50crypt++-gentoo.el b/app-emacs/crypt++/files/50crypt++-gentoo.el
new file mode 100644
index 000000000000..0009afdeff1c
--- /dev/null
+++ b/app-emacs/crypt++/files/50crypt++-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'crypt++)
diff --git a/app-emacs/crypt++/metadata.xml b/app-emacs/crypt++/metadata.xml
new file mode 100644
index 000000000000..59c5f3e28e24
--- /dev/null
+++ b/app-emacs/crypt++/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ crypt++.el is a package of Lisp functions that recognize automatically
+ encrypted and encoded (i.e., compressed) files when they are first visited
+ or written. The BUFFER corresponding to the file is decoded and/or decrypted
+ before it is presented to the user. The file itself is unchanged on the
+ disk. When the buffer is subsequently saved to disk, a hook function
+ re-encodes the buffer before the actual disk write takes place.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>