summaryrefslogtreecommitdiff
path: root/app-emacs/company-coq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-emacs/company-coq
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-emacs/company-coq')
-rw-r--r--app-emacs/company-coq/Manifest5
-rw-r--r--app-emacs/company-coq/company-coq-1.0.1_p20210708-r1.ebuild46
-rw-r--r--app-emacs/company-coq/files/50company-coq-gentoo.el4
-rw-r--r--app-emacs/company-coq/files/company-coq-refman-path.patch13
-rw-r--r--app-emacs/company-coq/metadata.xml21
5 files changed, 89 insertions, 0 deletions
diff --git a/app-emacs/company-coq/Manifest b/app-emacs/company-coq/Manifest
new file mode 100644
index 000000000000..b79c0d5076d7
--- /dev/null
+++ b/app-emacs/company-coq/Manifest
@@ -0,0 +1,5 @@
+AUX 50company-coq-gentoo.el 180 BLAKE2B df1fe948ed5daae78cbe5eee1f41dea6fee8bf09c309e1090b2af28252a3558796db3d84afaed41327b05a3410bb4097f5ba7cec717662cf6badf231423368cd SHA512 3d47c7646665dc1b25c4e84b249dec9b60c3e18f824bdbcdea4d086d4c6a9e8b250db2a769b08cb4eb71fa44ab05008066cd25ac91b1f7e6006f875fa441e33b
+AUX company-coq-refman-path.patch 490 BLAKE2B b4fb42289d969b324ebb946c79fb78989e4553910a330007195691b1e1a9add38dac10e12aee8f06b01d4e1575be9dd0f24904ec9376833a5028795a49d5f74e SHA512 097ab6ab479c2f0478877d077cfd6d9792c4b9807a4554e029ce6d76a1a45f728662fb245a94e0e9b9068a33c07a4edcb582f215548eccdb66d5a3bf1cd427f4
+DIST company-coq-1.0.1_p20210708.tar.gz 3803957 BLAKE2B d2bb3022228cc7a103d4343e914ec20cf539405062e475c7be6cd0db776490a7af35f10fc9e712733bd8f7c6667a05f8d3d6c4321820a61da0847b8bc718c182 SHA512 92a7d0bf8326460519e5f47fe1e9779a4cc2d2bf069898e1797fabf483535eca8244c1ea36bc525aac418e2c26036a8580076435ccbfaa5bdc2e6ee6f133b655
+EBUILD company-coq-1.0.1_p20210708-r1.ebuild 871 BLAKE2B d727e070d8888e8663e7b062a4a83eec1a7aa4911444b1da494c0865bda242bf36045136fd4eb2e81c2edc7043f2764d9415b5545e67776dfa58995007849c66 SHA512 96a495a1528d2f8b1ae827718d457b3af20cf59cc4fbe0dfef0e703671cdbaaae02e64a218c0e4c1ad16867290d06494c375041f277f39bf68fabd0041c45bf6
+MISC metadata.xml 905 BLAKE2B 85dc026f6b0fe495795fc3d3f8e41c4fc5470c95ab7d006ba181ab2cdbac1fc664ab69ded1a7a8588b30a4e5b58798f4f3c9e10564111c3abaf8d126524a87c8 SHA512 268fe6e3ad1e37417f9912d7af2ac9732d187a5830af63f9c4b8bc06ffbad1841c5bbaa934aa5d339313356c7bebbd4352ee1cab659a6ad89ec0ed9b0f503dd3
diff --git a/app-emacs/company-coq/company-coq-1.0.1_p20210708-r1.ebuild b/app-emacs/company-coq/company-coq-1.0.1_p20210708-r1.ebuild
new file mode 100644
index 000000000000..15a3bcbd6aad
--- /dev/null
+++ b/app-emacs/company-coq/company-coq-1.0.1_p20210708-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=382db93374380e5db56f02934ee32bbe39159019
+
+inherit elisp
+
+DESCRIPTION="Collection of extensions for Proof General's Coq mode"
+HOMEPAGE="https://github.com/cpitclaudel/company-coq/"
+SRC_URI="https://github.com/cpitclaudel/${PN}/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ app-emacs/company-math
+ app-emacs/company-mode
+ app-emacs/dash
+ app-emacs/yasnippet
+"
+RDEPEND="
+ ${BDEPEND}
+ app-emacs/proofgeneral
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-refman-path.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare(){
+ default
+
+ sed -i "s|@SITEETC@|${EPREFIX}${SITEETC}|" ./company-coq.el || die
+}
+
+src_install() {
+ elisp_src_install
+ einstalldocs
+
+ insinto "${SITEETC}"
+ doins -r ./refman
+}
diff --git a/app-emacs/company-coq/files/50company-coq-gentoo.el b/app-emacs/company-coq/files/50company-coq-gentoo.el
new file mode 100644
index 000000000000..9aa96abbd125
--- /dev/null
+++ b/app-emacs/company-coq/files/50company-coq-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'company-coq-mode "company-coq"
+ "Collection of extensions for Proof General's Coq mode" t)
+(add-hook 'coq-mode 'company-coq-mode)
diff --git a/app-emacs/company-coq/files/company-coq-refman-path.patch b/app-emacs/company-coq/files/company-coq-refman-path.patch
new file mode 100644
index 000000000000..96c642f1aea0
--- /dev/null
+++ b/app-emacs/company-coq/files/company-coq-refman-path.patch
@@ -0,0 +1,13 @@
+index 3a984878..9a42fed9 100644
+--- a/company-coq.el
++++ b/company-coq.el
+@@ -762,8 +762,7 @@ Useful as a value for `company-coq-completion-predicate'."
+ "Full path of this script.")
+
+ (defconst company-coq-refman-path
+- (when company-coq-script-full-path
+- (expand-file-name "refman/" (file-name-directory company-coq-script-full-path)))
++ (expand-file-name "@SITEETC@/refman/")
+ "Refman (and other assets)'s directory.")
+
+ (defface company-coq-doc-header-face-docs-and-sources
diff --git a/app-emacs/company-coq/metadata.xml b/app-emacs/company-coq/metadata.xml
new file mode 100644
index 000000000000..cdb2a2c4917d
--- /dev/null
+++ b/app-emacs/company-coq/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Company-Coq is a new Emacs package that extends Proof General with a
+ contextual auto-completion engine for Coq proofs and many additional
+ facilities to make writing proofs easier and more efficient. Beyond fuzzy
+ auto-completion of tactics, options, module names, and local definitions,
+ company-coq offers offline in-editor documentation, convenient snippets,
+ and multiple other Coq-specific IDE features.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/cpitclaudel/company-coq/issues/</bugs-to>
+ <remote-id type="github">cpitclaudel/company-coq</remote-id>
+ </upstream>
+</pkgmetadata>