summaryrefslogtreecommitdiff
path: root/app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
commit8fd9d385e5bc3c01115ec2ddcb2227607eb90861 (patch)
treeaba1e6ef6b95e94172c009394cd1fcbc383e7d6e /app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild
parent1ddcee0bd115d2f843f82061cb0d1741bf90151d (diff)
gentoo auto-resync : 05:01:2024 - 14:04:25
Diffstat (limited to 'app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild')
-rw-r--r--app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild b/app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild
new file mode 100644
index 000000000000..3a54a38e8409
--- /dev/null
+++ b/app-emacs/cmake-font-lock/cmake-font-lock-0.1.13-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="Advanced, type aware, highlight support for CMake"
+HOMEPAGE="https://github.com/Lindydancer/cmake-font-lock"
+SRC_URI="https://github.com/Lindydancer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-emacs/cmake-mode
+ dev-util/cmake[emacs(-)]
+ )
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}