summaryrefslogtreecommitdiff
path: root/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-05 08:03:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-05 08:03:20 +0000
commit1ddcee0bd115d2f843f82061cb0d1741bf90151d (patch)
tree20e516fd0fd41ce7f9f04e7ea8e7d8d3139af3f4 /app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild
parentc1c9e565a5696c10e991d8b5372f781ba5f13d5c (diff)
gentoo auto-resync : 05:01:2024 - 08:03:20
Diffstat (limited to 'app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild')
-rw-r--r--app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild b/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild
new file mode 100644
index 000000000000..15506aca0ab1
--- /dev/null
+++ b/app-emacs/citeproc-el/citeproc-el-0.9.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26
+
+inherit elisp
+
+DESCRIPTION="CSL 1.0.2 Citation Processor for Emacs"
+HOMEPAGE="https://github.com/andras-simonyi/citeproc-el"
+SRC_URI="https://github.com/andras-simonyi/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-editors/emacs-26:*[libxml2]
+ app-emacs/dash
+ app-emacs/f
+ app-emacs/parsebib
+ app-emacs/queue
+ app-emacs/s
+ app-emacs/string-inflection
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/ht
+ app-emacs/yaml
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l citeproc-test-human.el \
+ -l test/citeproc-test-int-biblatex.el \
+ -l test/citeproc-test-int-formatters.el \
+ -f ert-run-tests-batch-and-exit || die
+}