summaryrefslogtreecommitdiff
path: root/app-emacs/citar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 02:40:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 02:40:29 +0100
commitd498c2e6fb30b46f7db6e726a0edc1ba2b9d52b6 (patch)
tree38d6fdc95c4f4b1fc6c4453691276a37e3567f55 /app-emacs/citar
parentd91034bb707551b50209cfd2b2225da76fc88126 (diff)
gentoo auto-resync : 24:10:2023 - 02:40:28
Diffstat (limited to 'app-emacs/citar')
-rw-r--r--app-emacs/citar/Manifest2
-rw-r--r--app-emacs/citar/citar-1.4.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/citar/Manifest b/app-emacs/citar/Manifest
index d1099fcd4d88..220a90fde6a7 100644
--- a/app-emacs/citar/Manifest
+++ b/app-emacs/citar/Manifest
@@ -1,4 +1,6 @@
AUX 50citar-gentoo.el 69 BLAKE2B 4852ed7422e341e92f938dceedc3d6f0d0fdf8f955ef93021286d9d10e7c3a5d726175e2e79d34ca67f6815d7d6e0445ca2c9a80a2a6690daf4bda49d9972f96 SHA512 0afe62329cd2dc6ea548bbc28aa3c7fea86fb2a20febc91528ba994c77edf08fd72dcf1a0c417dcd4db75b4a6b8e237ade2257130ff3887499377b8f77fefc46
DIST citar-1.3.1.tar.gz 1602843 BLAKE2B 0abf90120860777e13ac495681bb1e07d6c352bc17aef173b32e60fc2d754a37628670b57e17335bc5e549c451b9565a58c8547952a5b78d6335adc7601b8f5e SHA512 a00e7ff5331fa3a161151292dd4a9d3c0a7211051f5ddf528cfe7d4a48377af64f3719f57c76013b45a30082fbfd435d98196e757169970a22bb662f49ccd346
+DIST citar-1.4.0.tar.gz 1604664 BLAKE2B 26ebe97a6701fa8c8d528ad0c6d750ea5acebda1fe6322c157fe62995140a9b3f16274888e51110a01dbd1681d7552637bc230d5d1e95270157bc524c037d7da SHA512 42ddb8eec21ad8c53b77b5ee235cd839fdb8d3a3efef8db28effd2bfc63d1d25c1031abb21df476e0243c99aaa619c2d1f29142f5569deb06281774c960924a9
EBUILD citar-1.3.1.ebuild 970 BLAKE2B 46a3cbb74f19170d3a8f1d95b0975fc6365451fa32cf66ae5cefef705ed49ebcea30ef22afba79b4c3143c379833681a97f793ea2bdfbce94f51f5e51e99f74c SHA512 1c2ca1b0caf356ad98dbe63c0a530420a8af693ef6bce69d4f3fa605f770ab270eae04612827a6d79c4dc56c89eca54ed89e741a7b344eb655ca40e21370698b
+EBUILD citar-1.4.0.ebuild 971 BLAKE2B 401d427cde0abd5caa7a50fe59a818cfc754ddd19685bce5c4320b209cb3f9b59172ec725f5f66baebd47eb2d1ebcb0a1f1e8001afbe66d932c916a0dbada592 SHA512 734aa260e166a2440c1cac97cd583d8d5abae7803bb00df4383b651e13da5430a03fa8cf1824175c1e44ec27d0b994f233fd1e50dd348c1abc676f7c6b91dc4e
MISC metadata.xml 1034 BLAKE2B 10d658566f58e3a91deab1c4d2035bcd25ee216777aa105b1e8c8853ab103add779f0f439e706496b2468a3fcb8490320ccb454d90c2e70b5b8bbe9f218773e4 SHA512 4b81115dfccc471987c63876c0b282875fe95c5738f69dfdf7a6300c37998102f2fdda829d14938871bd857fbb5d145e6c62b5b4be40b532f46245256d0be259
diff --git a/app-emacs/citar/citar-1.4.0.ebuild b/app-emacs/citar/citar-1.4.0.ebuild
new file mode 100644
index 000000000000..1e1644827e32
--- /dev/null
+++ b/app-emacs/citar/citar-1.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs package to quickly find and act on bibliographic references"
+HOMEPAGE="https://github.com/emacs-citar/citar/"
+SRC_URI="https://github.com/emacs-citar/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-emacs/citeproc-el
+ app-emacs/parsebib
+"
+BDEPEND="${RDEPEND}"
+
+# Embark integration has it's own package on MELPA, and it is probably better
+# to split them. https://melpa.org/#/citar-embark
+ELISP_REMOVE="citar-embark.el"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.org README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l test/citar-file-test.el \
+ -l test/citar-format-test.el \
+ -l test/citar-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}