summaryrefslogtreecommitdiff
path: root/app-emacs/circe/circe-2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/circe/circe-2.12.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/circe/circe-2.12.ebuild')
-rw-r--r--app-emacs/circe/circe-2.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/circe/circe-2.12.ebuild b/app-emacs/circe/circe-2.12.ebuild
new file mode 100644
index 000000000000..3f2b2daf64fb
--- /dev/null
+++ b/app-emacs/circe/circe-2.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A great IRC client for Emacs"
+HOMEPAGE="https://github.com/jorgenschaefer/circe
+ https://www.emacswiki.org/emacs/Circe"
+SRC_URI="https://github.com/jorgenschaefer/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/buttercup )"
+
+DOCS=( AUTHORS.md CONTRIBUTING.md NEWS.md README.md images )
+ELISP_REMOVE="${PN}-pkg.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . --traceback full tests || die
+}