summaryrefslogtreecommitdiff
path: root/app-emacs/buttercup/buttercup-1.27.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-20 01:59:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-20 01:59:18 +0100
commit9ed0c42eb618229fa6f45e10155ee535e1f605a2 (patch)
tree1cee221ce6610b86c942bdb5bd12aee04ac18642 /app-emacs/buttercup/buttercup-1.27.ebuild
parentadab5aeec61fe929e5a817ec8034d98caab9ddbe (diff)
gentoo auto-resync : 20:10:2022 - 01:59:18
Diffstat (limited to 'app-emacs/buttercup/buttercup-1.27.ebuild')
-rw-r--r--app-emacs/buttercup/buttercup-1.27.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/buttercup/buttercup-1.27.ebuild b/app-emacs/buttercup/buttercup-1.27.ebuild
new file mode 100644
index 000000000000..cfebece4d7cc
--- /dev/null
+++ b/app-emacs/buttercup/buttercup-1.27.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="24.3"
+
+inherit elisp
+
+DESCRIPTION="Behaviour-driven Elisp testing"
+HOMEPAGE="https://github.com/jorgenschaefer/emacs-buttercup"
+SRC_URI="https://github.com/jorgenschaefer/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/emacs-${P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DOCS=( docs/{running,writing}-tests.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -l buttercup \
+ -f buttercup-run-discover || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+}