summaryrefslogtreecommitdiff
path: root/app-emacs/bnf-mode/bnf-mode-0.4.5_pre20220102.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-emacs/bnf-mode/bnf-mode-0.4.5_pre20220102.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-emacs/bnf-mode/bnf-mode-0.4.5_pre20220102.ebuild')
-rw-r--r--app-emacs/bnf-mode/bnf-mode-0.4.5_pre20220102.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/bnf-mode/bnf-mode-0.4.5_pre20220102.ebuild b/app-emacs/bnf-mode/bnf-mode-0.4.5_pre20220102.ebuild
new file mode 100644
index 000000000000..8c438602742d
--- /dev/null
+++ b/app-emacs/bnf-mode/bnf-mode-0.4.5_pre20220102.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=d9329dd90e5d4f629295e85898362d9682047898
+NEED_EMACS=24.3
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing BNF grammars"
+HOMEPAGE="https://github.com/sergeyklay/bnf-mode/"
+SRC_URI="https://github.com/sergeyklay/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-emacs/buttercup
+ app-emacs/undercover
+ )
+"
+
+DOCS=( NEWS README.org )
+ELISP_REMOVE=".dir-locals.el"
+ELISP_TEXINFO="bnf-mode.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L test --traceback full || die
+}