summaryrefslogtreecommitdiff
path: root/app-emacs/blogmax/blogmax-20110305.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-emacs/blogmax/blogmax-20110305.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-emacs/blogmax/blogmax-20110305.ebuild')
-rw-r--r--app-emacs/blogmax/blogmax-20110305.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/blogmax/blogmax-20110305.ebuild b/app-emacs/blogmax/blogmax-20110305.ebuild
new file mode 100644
index 000000000000..07505c200b1f
--- /dev/null
+++ b/app-emacs/blogmax/blogmax-20110305.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils readme.gentoo elisp
+
+DESCRIPTION="Blogging in Emacs"
+HOMEPAGE="http://billstclair.com/blogmax/index.html"
+# taken from http://billstclair.com/blogmax.zip
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.zip"
+
+LICENSE="GPL-1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ rm *.elc gpl.txt || die
+ edos2unix *.{el,html,inc,ini,tmpl,txt,xml} docs/*.{html,txt}
+}
+
+src_compile() {
+ elisp-compile blogmax.el
+}
+
+src_install() {
+ elisp-install ${PN} blogmax.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ DOC_CONTENTS="To get started with BlogMax, use the example site file
+ from /usr/share/doc/${PF}/example as a template for your own blog."
+ readme.gentoo_create_doc
+
+ dodoc README
+ dodoc -r docs
+ docinto example
+ dodoc *.{html,inc,ini,png,tmpl,txt,xml}
+}