summaryrefslogtreecommitdiff
path: root/app-emacs/autothemer/autothemer-0.2.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-12 20:20:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-12 20:20:47 +0100
commit3d952d0bfe7b386699eb32d1431deb0c538f044d (patch)
tree45d2492f5c659cbb01120d4192c9be34841362bd /app-emacs/autothemer/autothemer-0.2.18.ebuild
parent522b6bf7e1f6133c288b94a77fc5e3d8eef2c179 (diff)
gentoo auto-resync : 12:06:2023 - 20:20:47
Diffstat (limited to 'app-emacs/autothemer/autothemer-0.2.18.ebuild')
-rw-r--r--app-emacs/autothemer/autothemer-0.2.18.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/autothemer/autothemer-0.2.18.ebuild b/app-emacs/autothemer/autothemer-0.2.18.ebuild
new file mode 100644
index 000000000000..9ed03806642f
--- /dev/null
+++ b/app-emacs/autothemer/autothemer-0.2.18.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+inherit elisp
+
+DESCRIPTION="Conveniently define themes for GNU Emacs"
+HOMEPAGE="https://github.com/jasonm23/autothemer"
+
+# Recompressed from NonGNU ELPA.
+SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-emacs/dash-2.10.0
+"
+DEPEND="${RDEPEND}"
+
+ELISP_REMOVE="${PN}-pkg.el"
+SITEFILE="50${PN}-gentoo.el"
+
+DOCS=(
+ README.md
+ CONTRIBUTING.md
+ function-reference.md
+)
+
+elisp-enable-tests ert "${S}"/tests -l "${PN}"-tests.el