summaryrefslogtreecommitdiff
path: root/app-emacs/anything/anything-1.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-emacs/anything/anything-1.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-emacs/anything/anything-1.3.2.ebuild')
-rw-r--r--app-emacs/anything/anything-1.3.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/anything/anything-1.3.2.ebuild b/app-emacs/anything/anything-1.3.2.ebuild
new file mode 100644
index 000000000000..6afe9363a764
--- /dev/null
+++ b/app-emacs/anything/anything-1.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="Open anything - QuickSilver-like candidate-selection framework"
+HOMEPAGE="https://www.emacswiki.org/emacs/Anything"
+# snapshot from http://repo.or.cz/w/anything-config.git
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extensions"
+
+S="${WORKDIR}/anything-config"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el || die
+ elisp-make-autoload-file || die
+
+ if use extensions; then
+ BYTECOMPFLAGS="-L . -L extensions" elisp-compile extensions/*.el || die
+ fi
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+
+ if use extensions; then
+ elisp-install ${PN} extensions/*.{el,elc} || die
+ fi
+
+ dodoc README doc/anything.pdf
+}